Cannot Install "Chris's Dynamic Compressor"

Hello, I am currently running Windows 10 home x64 with Audacity 2.3.2.

I am trying to install “Chris’s Dynamic Compressor” as described here, here, and can be downloaded here. Following the installation instructions, I copied and pasted the “compress.ny” file into the “C:\Program Files (x86)\Audacity\Plug-Ins” folder, then went to the “Effect” menu, then “Add / Remove Plugins…”, then click on “compress”, then “Enable”, then “OK”. However, I keep getting the same error message: “Effect or Command at C:\Program Files (x86)\Audacity\plug-ins\compress.ny failed to register: Ill-formed Nyquist Plug-in header”

I rebooted my computer, uninstalled audacity, re-downloaded and re-installed it, re-downloaded the plug-in, but all to no avail, I keep getting the same error message. Others must be having the same issue? Any help much appreciated.

The “Ill-formed Nyquist plug-in header” error, says that the plug-in “header” (the top few lines of the plug-in) fails to validate.

Did you download from ?
If so, please describe the exact steps to obtain the plug-in so that I can reproduce the problem.

Yes I downloaded the “compress.ny” file directly from gethub. But it appears to be an issue with Audacity 2.3.2; according to this page the plugin works with Audacity 2.3.0

Perhaps this is an issue for the developer to correct? Unless somebody else is able to make “Chris’s Dynamic Compressor” work with Audacity 2.3.2 on Windows 10.

OK, so I installed Audacity 2.3.0 and I got the same error code, so it isn’t just Audacity 2.3.2 that has issues with it. But others have still reported the same issue here.

Yes, and it also works with Audacity 2.3.2 and even 2.3.3 alpha (I’ve tested), so it seems there’s something wrong with your copy.

So I go to this page:
and then what?

Here’s my screen capture video which shows how I install the plugin from start to finish:

You’ve downloaded a web page instead of the plug-in file.
Here is the file that you want:
compress.ny (16.9 KB)

Thank you very much. I can’t believe I made such a simple error. I was supposed to LEFT click “compress.ny” which brings me to the next page where I download the “Raw” file. Instead I was RIGHT clicking “compress.ny” and selecting “save as” which means I was downloading the entire web page! What’s odd is that normally when I download a web page it would have a “.html” extension, not a “.ny” extension. Anyway, thanks again. Hopefully this page will benefit someone else making a similar mistake.