Cannot install Audacity (PCPitstop / PCMatic) [SOLVED]

I’m out of ideas, but as a (mostly) Linux user I’m not very familiar with the Windows permissions system, so I’ve asked some of the other forum crew to take a look and post if they have any ideas.

OK, have a look at this page: “Windows cannot access the specified device, path, or file” error when you try to install, update or start a program or file

Just a shot in the dark here - try googling “Windows 10 spaces in username”. I see that your username has a space in it from the image you supplied. While Windows allows this, lots of folks experience problems with this feature.

You have the zip file. Place that zip file in your “My Documents” folder - a location for which you absolutely are certain to have read/write permission. Double-click the zip file; Windows (File) Explorer will open the zip file:
Make sure that (1) the “File” menu is selected in the ribbon; then click the “Extract all” button. A dialog will open asking where you want to extract the documents; it should default to your “My Documents” folder (because that is the folder in which the zip file resides) - that is what you want. There is a checkbox “Show extracted files when complete” - make sure it is checked. In the bottom right-hand corner of the dialog there is an “Extract” button - click it. After a few seconds a new Windows Explorer window will open - I do not have a copy of the zip file on hand so I don’t know exactly what you will see. You will probably be looking at a newly created folder that has the word “Audacity” as part of the folder name. You will be seeing at least one additional folder in this newly created folder.

If there is only one folder in that newly created upper-level folder double-click it and see what is inside. Keep doing this until you come to a folder that has more than one item in it - that is the folder that you want to drag somewhere for the installation. If you get lost in this part of the process, let me know and I will download the zip file so that I can give you exact steps.

I will subscribe to this topic for a while so that I see your questions.

FYI – I was sure that I was the only User - but as it turned out,
PCPitstop had entered another User account (!?!)
Deleting that seems to have solved the problem.

That and this…

Screen Shot 2021-04-29 at 2.33.42 AM.png

Well done figuring that out.
(You might want to report that bug to PCPitstop / PCMatic.)

I’ll close this topic as “solved” so that it is easier to find the solution in future.
Thanks very much for letting us know how you fixed it.