Cannot get Stereo Mix to record

Audacity 3.0.5 on Windows 10
I have headphones and a microphone plugged in (via separate jacks) to the computer front panel. The only speakers I have are thru the BenQ monitor.

Recording via the microphone works fine. I hit the record button and everything just works.
I have enabled Stereo Mix; it advertises itself as an enabled Recording device in the Windows Sound dialog box. In the Properties box, I have the choice of 2 channel 48KHz 16 or 24 bit. I’ve set it to 24 bit. Note Stereo Mix becomes the default device when I unplug the microphone.

I unplug the microphone and play some audio in a browser. I can hear it in the headphones. In Audacity, I set MME / Stereo Mix / 2 (Stereo) Recording Channels / Microsoft Sound Mapper - Output, and the Project Rate to 48000. I hit the record button and recording starts, but the waveform is flat. Note that the Audio track advertises itself as Stereo, 48000Hz 32-bit float.

I tried initializing a new track to Stereo, 48000Hz 24-bit PCM and recording with that, but that had no effect.

I tried specifying the other choices as output: “Realtek HD Audio 2nd output (Re”, “BenQ LCD (NVIDIA High Definito”, “Realtek Digital Output (Realtek” but none had any effect. Note that I continued to hear the music thru the headphone with all these settings.

The record volume is all the way up (as noted, microphone records fine), and Transport → Transport Options → Playthrough is off; Overdub is on.

This is my first time trying to do any recording whatsoever, so I’m probably making a simple error. Any help would be appreciated. Thanks!

Try [u]WASAPI (loopback)[/u].

Windows WASAPI / Stereo Mix (Realtek High Definition Audio) / 2 (Stereo) Recording Channels / any output behaves the same way (records, but no sound)

Windows WASAPI / any other input value either turns the track position triangles red but doesn’t record at all, or generates an Error code -9997 Invalid sample rate. Frustratingly, I did get it to record once (which means the system is theoretically capable), but a retry with no settings changed yields the error.

I don’t know what the red triangles or error codes mean but hopefully someone else can help.

I believe Stereo Mix and loopback are both driver features. Stereo Mix is becoming rare but loopback works with the “standard” Microsoft-supplied WASAPI drivers and most Realtek WASAPI drivers.

[u]Total Recorder[/u] ($18 USD and up) has it’s own virtual driver and it’s supposed to be foolproof. [u]Virtual Audio Cable[/u] (“donationware”) may be another solution. (I haven’t used either of these.)

This is my first time trying to do any recording whatsoever, so I’m probably making a simple error. A

Or not. Computers only have two sound pathways. Play something like a sound file or YouTube to your headphones [full stop] and Record your microphone to a recording program such as Audacity.

That’s it. There is no natural playing something into a recorder. Crossing the two natural pathways requires special software, drivers, or programs.

That would only be a simple programming task except for the political problem. The music companies and vendors would just as soon that software never see light of day. Copyright and marketing issues. You’re stealing their product.

So no, this is not “making a simple error.”

Even if you do get it running, you may stumble over Chat, Skype, Zoom, and Meetings which like to take over your computer’s sound services and sometimes don’t put them back when they’re finished. Never leave any of those napping in the background when you’re trying to do sound production.