Cannot Get Audacity 2.4.2 to record. Tried everything--even two different computers.

Is anyone having problems getting Audacity to record, or recognize a microphone? I desperately need help with this problems.


You need to give Audacity permission to use the microphone.

Thanks Steve, but I don’t think this is the problem. It was fine one day, and the next, this started happening.

So, as I said, I tried my other computer which I was using Audcaity on for years, and the same exact thing occurs.
The green colored sound meters are moving, like something is making a sound, but when I talk itno the mic, nothing happens to the green colored meters, they just continue to move back and forth with no sound from the interface that I’m using coming through.

What interface are you using?
What settings do you have in the Device Toolbar?

Hi Steve,

Thanks for getting back with me.

I’m using the MME Audacity setting. I’ve tried all 3 selections, and still can’t get anything.
I’m using the Behringer U Control UCA 202 Interface.

Here’s one detail I forgot to mention…while I have everything set to record, on the Interface, there is an “On/ Off” switch for the monitor.
I mentioned that when I set everything on Audacity to record, I have the Record button placed on “record”, and have the pause button set so that all I would have to do is click on the Pause to release it from pause and begin recording. While it’s on pause, the two green meters are both moving back and forth as if they’re receiving sound.(See image ) They are doing this while nothing is connected to Audacity. Then, when I have everything connected to the Interface, the Interface connected to my computer, and Audacity set to record and placed on Pause, if I were to turn off (or on) the monitor switch on the Interface, the meter bars both jump all the way to the end of each meter as if a surge of sound was just made, then they SLOWLY move back down to the position they were in initially and continue moving back and forth as if signaling sound coming in. It does this on both computers. At the same time, the meters on my mixer through which the mic is connected are working, which means there is no microphone problem, and that the mic is working. I’m just completely baffled. :frowning:

I’d suggest that you ignore Audacity for a minute and look to see what is happening in Windows.
Quit Audacity if it is currently running, and open the Windows Sound control panel (more info here:
In the “Recording” tab, you should see a green meter to the right of the (Behringer) USB device icon, and it should move in response to audio input.

When you’ve got that working, then I expect Audacity will work with your current settings.

The Behringer units come out of the box as plain sound devices. Record from a microphone or other device plugged in, and play computer sound to your headphones. The Monitor switch lets you hear your own live sound on the way to the recording system. You need that if you intend to overdub or sound-on-sound. The Behringer will mix your own live sound with the computer playback. What I call a perfect theatrical mix.

You would think you could do that with Audacity, but sound coming from the computer almost always has a delay or echo which is missing in the Behringer Monitor point.


Hi Steve,

I followed your instructions, and I see the green meter next to USB Behringer device, abd followed the directions in the link you shared with me to get the info from my set up in Windows, but the green meter in the recording tab is there, but it is not working. I’ve tested the mic, and everything is working with the mixer according to the meter lights when I tap on it.

Do you have a different sound source that you can plug into the UCA202 for testing purposes? Perhaps a CD player?
Also, check your leads - if possible, try different leads.


Thanks for all your help, Steve. From all indications, it’s the Interface. I plugged the headphones into it, and there’s a faint but noticeable ringing sound in it. When I increase the volume for the computer speakers/headphones, an very strange pattern of sound becomes very audible. I then hit the record button on Audacity to see if it was picking up the sound from the Interface, and it is, and then when I increase the volume on audacity microphone level, it produces the wavy sound pattern that you see in the image attached when recorded by Audacity. My (unprofessional) assumption is that this would explain the green meters moving as if sound is being picked up during record, while the microphone is not producing any sound due to whatever is wrong with the interface. Does this sound like a correct assumption?

Perhaps, but let’s not jump to conclusions.

How exactly is everything connected up?

Very curious, from your image, audacity is not sending anything to your “computer speakers/headphones”. Do you have “Listen to this device” selected for any of your input devices?

Also, just to double-check, exit Audacity (or do Transport > ReScan), then reselect your input and out devices.

Hi Steve,

Please keep in mind that this worked fine for months, then one day, it just stopped working.

I have a microphone running through a “h TC Helicon Voicetone” pedal. This pedal is then connected to a Moog Ring Rodulator (called a "Moogerfooger). The Moog is connected to an Alesis mixer. The Interface is connected to the Alesis mixer and the computers USB plug in.

What is “The Interface”?

SOUNDS Recording Tab Opened.png
Hi Jademan,

Thanks for your comment.

The sound being produced(which creates the image you see on the Audacity screen) is being picked up evidently from the computer, and I am able to hear it and record it using Audacity?

When I read your response last night, you’d included a link that took me to a display in my “Hardware and Sounds” program.
I noticed that in the column in the “Sounds”, which includes tabs that read " Playback Recording Sounds Communication". I do not see the little PC board that I saw in the image that you posted regarding “Stereo” nor anything that says “Stereo Recording” in the tabs when I click on “Recording” or “Playback” tabs. All I have listed is what you see in these two attached images, under the tab “Recording” and “Playback”.

"Do you have “Listen to this device” selected for any of your input devices?

Also, just to double-check, exit Audacity (or do Transport > ReScan), then reselect your input and out devices."<

I am not sure that I understand where the ""Do you have “Listen To This Device” is located, and don’t know where to find where to reselect “Input and devices”. :frowning:

It’s made by Behringer to record musical instruments through a mixer onto Audacity or any computer recording device.

OK, from the “Sound-Recording” windows, which you have posted above, Click on Microphone, then (Device) Properties. Then select Additional Device Properties. Then select the Listen tab


Click on the “2-USB Audio CODEC” icon, then select “Properties”. Find the recording level in there and ensure that it is turned up.
When the interface receives an audio signal you should see the meter (the bars to the right of the icon) indicating the audio level with green bars.

If you don’t see the meter moving, try connecting a different sound source to the interface, such as a CD / cassette player.

Hi Steve,

Thank you for the instructions.

I did as you instructed by connecting a cassette player to the interface and then through the computer. The meter activates, but it doesn’t move up and down with the sound, it just stays at the very top of the meter. I plugged headphones into the headphone input jack on the interface to see if I was getting sound through speakers, and there is sound. So, I then hooked up the microphone, connected to everything I mentioned before i.e. ring modulator, TC helicon interface connected to mixer, and plugged into the USB on the computer. The meters on the mixer indicate it is receiving sound from the mic, as does the ring modulator and the helicon, but Audacity still does the same thing I mentioned before. The meters on Audacity are jumping back and forth–even with the mixer/mic turned off.

If Windows does not hear the interface, then Audacity will not be able to either.

and the meters in the Windows Sound control panel?
Ignore Audacity until you have the meters in the Windows Sound control panel working.