Cannot delete parts of MP3 [SOLVED]

Attempted simple deletions of part of an MP3 file (podcast). Selected a segment, but found no ‘cut’ or ‘delete’ on the Edit menu. Labelled the section in question but then on Edit>Labelled Regions, the ‘Cut’ and ‘Delete’ options are greyed out, inactive. Sorry if I’m missing something really stupid.

Audacity 2.0.2
OS Version: Microsoft Windows 7 Home Premium, Service Pack 1, 64 bit
Processor: Intel(R) Core™ i5-2410M CPU @ 2.30GHz, Intel64 Family 6 Model 42 Stepping 7
Processor Count: 4
RAM: 3979 Mb
Graphics Card: Intel(R) HD Graphics Family, 1797 Mb
Hard Drives: C: Total - 459437 MB, Free - 224753 MB; Q: Total - 15999 MB, Free - 4113 MB; S: Total - 1499 MB, Free - 1162 MB;
Motherboard: LENOVO, 41772VB
Antivirus: Microsoft Security Essentials, Updated and Enabled

(Facepalm)…please scratch this and mark it solved. I was in ‘pause’ mode and not ‘stop.’ 'If all else fails read the instructions. Sorry for wasting your time.

I’ve never tried it with labeled regions, but you can just select/highlight part of the audio and then Edit → Delete, or just hit the delete key on your keyboard.

FYI - As you may know, MP3 is lossy compression. When you open an MP3 in Audacity (or any “normal” audio editor) it gets decompressed. If you re-save (re-export) to MP3 you are going through a 2nd lossy compression step. There are specialized MP3 editing programs such as [u]MP3DirectCut[/u] that can do some limited editing without decompressing.

Yes. Everything gray is a common red flag (so to speak).

Thanks for all the system information. 2.0.2 is old now. Consider updating Audacity to the latest 2.1.1 from