cannot connect microphone

I have a fancy microphone attached to a box which has a usb connection to laptop running linux mint 17, I cannot get audacity to find it - it seems to be using some default onboard mic, the device toolbar and view-preferences are both greyed out.

You don’t give your Audacity version (see Help > About Audacity…) . You seem to have a bogus version of Audacity - our code has Preferences under the Edit Menu.

Have a look at the Build Information tab of About Audacity. If it says anything higher than Widgets 2.8.12 then you have a broken version built with the wrong version of Widgets.

To enable menus and Device Toolbar, press the yellow Stop button.

To let Audacity find a newly connected USB device, restart Audacity or use Transport > Rescan Audio Devices.


audacity 2.0.5, yes preferences was under edit not view, I did the transport rescan audio and now to the right of the microphone icon there is HDA Intel PCH:ALC283 Analog which is presumably it. I have tried daws twice before without getting the hang of things, is there a beginners tutorial?

What is the make and model number of the mic? Is it a USB class compliant plug and play device or is it meant to be used on Windows with proprietary drivers?

If it appears in Audacity it should look something like “USB Audio CODEC - (hw: 1, 0)”.

If you ever want to choose input devices belonging to the built-in audio device, it is recommended to install Pulse Audio Volume Control (pavucontrol) then choose the pulse input device in Audacity’s Device Toolbar.


Pre Sonus M7 high definition condenser microphone is all I can find out. It came in a package: microphone, headphone, AudioBox USB, leads, Studio One artist cd. | have just looked it is for Windows and Mac. I tried the cd but nothing happens on linux - I was hoping to install it under wine. When I brought it about three years ago I tried it and nothing much happened and from what I could gather from their help forum this was because the computer that I was using was under powered. The reason that I got it in the first place was the hardware looked a bargain, I think that this was because Pre Sonus wanted people to use their daws rather than the others on the market, I found their instructions and forums not much help all they did was go on about how much better their daw was, this was all gobly-goocke to me at the time as I did not even know what a daws was.

As far as I can see, Presonus AudioBox USB should work on Linux without special drivers.

If you open a terminal with AudioBox connected, what output does

cat /proc/asound/cards

give you?


$cat /proc/asound/cards
0 [PCH ]: HDA-Intel - HDA Intel PCH
HDA Intel PCH at 0x90810000 irq 108

there is a bit of space between the PCH and ] which does not show on the preview,
my terminal is a nice orange colour - colour 3 in bashrc…

no idea if that command is giving info about some card in the machine, some
microphone in the machine or something connected to the machine…

ALSA is not recognising your AudioBox, so pulse probably won’t and Audacity won’t.

This may be something specific to your machine and Linux Mint. I would ask here Hardware Support - Linux Mint Forums.


I’ve checked, I get the same result whether of not the audio box is plugged in and when I go up and down the path.
I have just registered with the linux mint forum so hopefully will be able to post there tomorrow.
Presumably to refer to this thread one simply copies the url like so:

Use cannot connect microphone If you give them a reply URL they will receive an error that they are not logged in.

posted but not solved

here is the mint link
also there is this link on linux musicians