Cannot activate VST addons/plugins

Hello, i have a big problem : i’ve got 5 VST plugins that i can’t activate.
Basically, Audacity detect them when i go into the “add/remove plugins” window (they are in the Steinberg folder) but when i try to activate all of my new plugins, it seems like it did activate them (doing the loading thing and all that stuff) but they don’t appear in the effect list. And also when i come back into the plugin management window, it says that they are not activated. I’m very confused, and i searched the internet to see if someone has the same problem (i found 1 person but nobody answered to him). So please can you help me, thanks

That means Audacity on Windows can only use (some*) 32-bit plugins.
(Your “new plugins” are probably 64-bit, so cannot be enabled to work with a 32-bit app).

[ * VST & VST2, not VST3 nor VSTi]

Also, note that Audacity 3.0.3 is just around the corner, which is expected to support 64-bit plugins. See:


I have the exact same problem with audacity 3.1.3 (installed via snap under Debian 11). I tried to install gsnap autotune plugin and Graillon2 plugin but they could not be actually activated.

I noticed that all other plugins are ending in .ny whereas those I want to install are shared object libraries .so files. I moved them under snap folder/current/plugins

Can audacity use .so files as plugins indeed ? If so what shall I do ?

Any help appreciated

Sorry, I don’t speak Linux, but you may be able to glean a clue from this thread here:

If that doesn’t help, you may have to wait for our resident Linux guru.

Hey thanks a lot jaderman!

The link you pointed me to did the trick.
To summarize snap version of audacity seems to disable external plugins. Consequently I had to :

  • download this very cool appImage which suggested me to download a newer version (3.2.1 at the time of writing).
  • copy the GSnap plugin to a newly created ~/.ladspa
  • open the Plugin Manager in AUdacity, clicked on rescan, the GSnap plugin appeared deactivated, so I activated it but it did not work (please not all other ladspa plugins shown in this list end with “;0” (eg /usr/lib/ladspa/;0) except GSnap that I added)
  • close and reopen Audacity and it showed that the GSnap plugin was not compatible and had been deactivated.

So this was cool to finally get this popup showing me the problem.

I also created a ~/.lv2 directory and put the whole Graillon2 LV2 folder as explained in the manual and upon restart the Graillon2 effects were already enabled!

So bottom line : use the appImage!

Thanks again jaderman!

:blush: Even a blind squirrel finds a nut once in a while! :blush:

I glad to hear you found a solution. :smiley: And thanks for posting it! :smiley: