cannnot start after changed temp files directory[SOLVED]

hey hey
I changed temp directory and now can’t start audacity even after complete unintall and install again.

nothing happens after OK, except core dump

i created manually folder /tmp/audacity-
same effect

And I have libgail packages: libgail-common, libgail-3-0, libgail18. No libgail-gnome in ubuntu’s channel.
I have audacity 2.0 for ubuntu 12.04

plox help, thanks :ugeek: :nerd: :ugeek: :nerd: :ugeek:

It’s a bug that Audacity crashes if it cannot find a place to write the temp directory.

Make sure you are opening Audacity from Applications > Sound and Video. Don’t open the app from the /usr/bin folder.

If the problem persists, open ~/.audacity-data/audacity.cfg and change TempDir under the [Directories] line to a folder to which you have write permissions. If you do not see audacity-data, show hidden files and folders in your file manger program.

See here .


Thank you so much, it fixed my problem. I had real directory it that line, which is not on system disk but on mounted ntfs partition - I guess Audacity doesn’t handle that, right?

Ubuntu can write to mounted NTFS volumes on the same machine so I don’t see what the problem was if you really had permission to write there. Did you create the path in the Directories Preferences of Audacity by browsing? For example on a netbook where I dual boot Ubuntu 12.04 and Windows 7 I can write to my Windows 7 Users folder from Ubuntu by browsing then let Audacity create the folder it wants. This is:

/media/Windows 7/Users/gale/.audacity_temp/

If this NTFS partition is on a network, that could have time outs, and isn’t recommended because access could be too slow for recordings.

If Audacity could not write to the specified folder then it should have tried the default /var/tmp/audacity- - that is what it does for me if I set the temp directory to /media/Windows 7/Users/gale/.audacity_temp/ then unmount the partition before launching Audacity.


Gale Andrews

Yes, I have all permissions and partition is always mounted. I did like that: edit>preferences>directories>Location>Choose and browsed and chose directory which i created previously, in my case “/media/data/audacity_temp” - audacity_temp folder is created by me.
After audacity’s restart I got error above.
It’s strange, because I have no problems with saving files in my “/media/data/” partition from Audacity.

OK so if you selected the directory “/media/data/audacity_temp” as had been created by you, Audacity would write the following to the “Location” text box in Directories Preferences:


That works for me, but the temp folder insider the temp folder may not be what you intended.