Can record one track - cannot record another one

Ubuntu 20.04
Audacity 2.3.3
Distribution release
Focustrite 2i2

Plugged in my new Focusright 2i2 to the USB on my system. Plugged my acoustic into channel one and set the levels. Plugged in my headphones and got a good mix. I have direct monitoring on.

Fired up Audacity to record a new song. Found out I had to set Audio Host to Scarlett 2i2 USB Audio. This seems to set the recording device to the same thing. Set Recording Channels to 1 and Playback device to default. Preferences: Devices say the Host is ALSA, Playback: Default and Recording: Scarlett 2i2 USB Audio. Overdub is on, Software Playthrough is off.

Hit Shift-R and record a couple of chords. Checked the playback, they sound fine. Time to record track 2.

Hit Shift-R again and I get a new track but the recording doesn’t start. I hit the record button and see the green Play button flash and the black square Stop button flash and the recording stops immediately. I can’t get my guitar to record the second track! I hear the guitar in my headphones but Audacity never records anything nor plays anything back. I can hit playback and I hear Track 1 and I can play along it with but nothing is recording.

Your setup does not want to record and play at the same time.
This “may” be due to the Focustrite being fussy about the sample rate. To test this possibility:

  1. Close and restart Audacity with a new, empty project.
  2. Set the “Project Rate” (lower left corner of the main Audacity window) to 48000
  3. Record a short track
  4. “Shift + R” to start recording a new track.

Any better?

You know I had not touched that setting and it was set at 41000 before. I fired up Audacity and this time it worked! Don’t know what I did different.

Later I went to record some stuff and re-recorded the rhythm guitar. I was able to play along with the pre-recorded track and record a separate track of rhythm guitar. Great! Started playing along with the tracks recorded so far and got some ideas of additional guitar tracks I wanted. So I recorded a new track (Shift-R) with a single note thing. Great. I’m really going here. Now I wanted to record yet another track with a harmony to the single note thing. Hit Shift-R for a new track and again I got struck. Record starts and immediately stops! I touched nothing else. WTF! In theory I should be able to do Shift-R and record a new track using my guitar as many times I as want to right? I mean this is overdubbing right? Why can I record a rhythm track this way and then a separate track with a single line thing but then that’s as many tracks as I can record?!? Makes no sense!

Why does it again refuse to record on another fresh track?!?

Yes, up to the point where your hardware can’t keep up. On a modern machine that should be a lot of tracks.

Have you tried my suggestion about 48000 Hz project rate? The outcome of that test will be helpful for diagnosing the problem.

I have 32 Gigs of memory and 16 CPUs. I think I should be able to record more than 3 tracks!

After you suggested to change the project rate to 48000 I went into Audacity and tried that. To my surprise, it worked! I then set it to 44100 and that worked too. Scratching my head I assumed that changing the project rate to 48000 wasn’t really what fixed it. I stopped and restarted Audacity and left it at 44100 and it works. Ok great. Let’s do some recording.

So I opened up my project (my friend wrote an original and gave me two tracks - one of guitar and one of synth) and proceeded to record a new rhythm guitar. That worked. So then I did another track with the single line thing and that worked. It’s when I tried to record another new track of a harmonized single line thing that it stopped working. This was last night. I tried all kinds of things to get it going again like restarting and the project rate thing. Nothing fixed it. I went to bed.

So here’s what I did today I restarted Audacity again, opened my project, and simply tried to record a new track. Now it works again but the recording stops after about 2 seconds. Tried this several times. Sometimes I get about a second’s worth of recording. Other times it’s like 2 or 3 seconds. Odd, so I restarted Audacity, reopen my project, and now it seems to record new tracks without issue. However why this odd behavior?

It’s a real bummer when you’re on a roll and have ideas you really want to get recorded so you don’t forget them and this happens and you have to shut down and restart to get it to work. Or you shut down and restart and it still fails. Then you’re in the mindset of fixing this problem and your creative juices stop flowing and the creative ideas you just had go away as your mind is now focused on fixing the problem. I really want to get to the bottom of this or at least have a number of steps or tools or things I can try to get it working again quickly. Just changing the project rate doesn’t seem to do anything. I would think that if Audacity records any track successfully then the project rate is just fine, no?

Oh, I did want to mention that while trying things today I did get the following error dialog once:

It only happened once and thereafter it seemed to be able to use the recording device (the Focusrite)

My (Linux) PC has 8 GB RAM and 8 CPUs and can easily manage over 100 mono tracks.

“Only” changing the project rate is unlikely to to be helpful.

I have a hunch that the problem may be to do with the Focustrite not performing reliably when resampling is required, which will be any time that there’s a mismatch in sample rate anywhere in the system. I think the “native” sample rate for the Focusrite is 48000, hence my suggestion, but for the suggestion to work as intended, the Project rate and all track rates need to be 48000.

My hunch may be off the mark - it could be something else entirely, but it’s my best guess at this point (unless you can positively rule it out).