Can import MP4


I’m trying to teach myself how to record and make my own game videos for YouTube but I’ve ran into some issues. Maybe you can help me figure it out.

I have audacity 2.3.0, OBS studio 22.02 64 bit- windows and adobe premiere elements 2019, windows 10 (its from the upgrade).

I make a video using obs while playing the game and I can even record with my head set/mike. I even get nice video too.

However, now that I’ve done that, I want to do more.

In OBS: First I save in MKV because that was recommend to keep from loosing files. Then I remux to convert it to MP4. My next step was to edit in adobe and I’d get a decent end result. I am getting a big file for a 40 min video so I’m still trying to work that one out.

What I want to do since I get tongue tied playing the game and talking sometimes I want to try something different. That is where audacity comes in. I want to save my game play, and if need be I can still use the mike or not if possible.

What I’d like to do, is save the game play with obs. Then put the saved file into the editor. Watch the game and use Audacity to narrate. Save the file in Audacity so I can put it into the editing software and hopefully get a nice end video. I don’t care how good it is as long as I have a place to start learning to get better. It’s taken me 2 weeks to just get to recording and editing what I have.

I saw the YouTube tutorials where I can just drag the mp4 file over to audacity and I’d get the audio. I tried this with one of my saved raw videos.

I tried to export my mp4 I made with Obs to audacity. I am doing this to get the audio channels so I can seperate game sound from mike voice. Then I want to watch the video and create a new mike voice over or recording to replace or add to my video.

I was under the impressing if I used editing software (adobe elements) I could put it all back together, my game play and sound, my mike narration. So it is one video.

I think I have my obs setting correct. Watched a couple of videos on that.

I hope I have audacity set up right. It now works with my headset and snow ball mike.

So when I try to import or copy to audacity this is what happens.

I get the following message G:\obsraw\fist take mp4.mp4 is and advanced coding file. You need to convert to a supported audio format such as wav or aiff.

There was a question mark so I hit it and it took me to audacity’s page which said [You can install the optional FFmpeg library to import a much larger range of audio formats including AC3, AMR(NB), M4A, MP4 and WMA (if the files are not DRM-protected to work only in particular software). FFmpeg will also import audio from most video files or DVDs that are not DRM-protected]

I did that.

I’m not sure what which plugin to use but all are enabled after that. I can list them if you need me to, however, my post is already a short novel. :slight_smile:

I made sure I downloaded the first one that said it was for my system and the later versions . I have audacity 2.3 from the website. I have obs studio from their website, and I have a retail copy of adobe premier elements 2019.

Also, I did try other file names. The one I used was to tell at a glance which file I was importing. It should not be an issue. I’ve actually tried to do the same thing with a new recording using a generic file name w/o the extra mp4 so I don’t think my file name is the problem.

Sorry this is so long. I’m hoping you can help figure out whats going on. In the mean time I’ll keep looking at some of the audacity and obs tutorials and make sure all of my settings are correct.

I hope you can help me figure this out.

Also a special thanks to buanzo for helping me get my user id working so I can get on the forums. It gave me an improvement to a very frustrating day.

You need to install “FFmpeg”.

The download page for FFmpeg also has “LAME”, which is something different. The file that you need is called: “DMG - ffmpeg-mac-2.2.2.dmg”. Search this page for “DMG - ffmpeg-mac-2.2.2.dmg”

When you have the correct file, follow the instructions here to install FFmpeg: Installing and updating Audacity on Mac - Audacity Manual

That looks like that is a mac file. When I downloaded the one for widows had win in the name.

I downloaded the one for widows because I have the windows system.

If I am wrong please let me know. I thought I downloaded the correct file already. Are you saying I need another?

:confused: For some reason I must have thought that you used a Mac.
For Windows, it’s the same download page ( and the file is called:
“RECOMMENDED Installer Package for Windows: Lame_v3.99.3_for_Windows.exe”


I found out a few things.

Found another YouYuber who explained you had to add the files to your library. A huge step I wasn’t aware of. I did an install and the ffmpeg program didn’t install the files to my library. I had to do that manually. The program didn’t. The zipped file only unzipped leaving a list of .dll files. That was confusing since it did not do an install, but now it makes sense

It explains the zip file and the lame file too.

Once I went into the library and followed the instructions they gave for that, I was able to read my audio tracks. Also a different YouTuber was explaining obs and showing a few things about separating the tracks. I’d seen the other YouTuber explaining it and he went faster than this guy.

The YouTuber that helped me figure it out said something that made me look over at audacity and I noticed that when I moved the file over, I had to select the file to import to audacity. I just spotted it as I was taking the time to follow the new guys instructions.

So I can now record via obs, then import each track separately into audacity. Then clean up audacity w/o changing the size of the track to keep it in sink w/ the video. Then merge it all together with my adobe premiere elements.

It worked.

Now I just need to practice doing it and I bet it will improve over time.

Next I plan to add my snowball mike instead of my headset mike.

thanks for trying to help me. I hope this helps others.

Hooray! :smiley: Very pleased that you are now up and running.

Thanks for posting an update. I’ll close this topic as solved.