Can I adjust audio balance?

I have a music track that has the left audio louder than the right. On my home entertainment system I have established that I need 5.5 more decibals in the right channel in order to ‘center’ the audio.

I thought the pan slider might work, but it appears it only affects playback of a track I already recorded when importing (i.e., playing into the computer, using digital audio in ) and does not affect the recording process itself.

How can I get this done?

If the goal is to play the music in an entertainment system, then the balance slider should work just fine – although the show on the timeline will still be out of balance.

Select the whole show by clicking just above the MUTE button.

Effect > Normalize, select everything and normalize to -1 > OK.

This will fail is you have a noisy recording or anything technical wrong with it.

In that case you can do it manually:

Drop-down to the left of the track > Split Stereo Track.

Select either the low one and Effect > Amplify to bring it up, or the high one and Effect > Amplify and bring it down.

Left Drop-down > Make Stereo Track.


Should I check the 'normalize stereo channels independently? I’ll try this tomorrow. The other two check boxes come checked by default.

You might be able to change the left-right input balance in Applications/Utilities/Audio MIDI Setup.

Yes you will need to check the box to normalize independently, since you want to change the stereo balance. If you leave that box unchecked, it will only give the loudest channel a peak of -1 dB. It will scale the other channel up or down by the same amount by which it modified the loudest channel.


OK, I’m better able to find things in the help file, so I found the explanation for the normalization.

After I ran the procedure, the overall volume of the track increased quite a lot, obvious on the wave form and noticeable in the home entertainment system, but it did equalize the tracks.

I thought the gain slider would affect the overall volume of the record. Since there was a 5.5 db difference in the original, and not understanding the finer points of gain control, I set the gain at -5.5, re-recorded a new track (only 5 mins long so no big deal), ran the normalization, but the wave form looks just like before, too loud in comparison to my other tracks.

Then I tried the midi interface which you suggested. I’m on a Mac. The volume adjustments for the built-in input are greyed out. For the built-in output, my only available source is internal speakers. The M line for volume control is greyed out, but the L and R are available, both defaulting to -32.5 dB. So took a stab at increasing the negative value to 38 (minus 5.5), re-recorded, normalized, but still the overall volume is louder than all my other tracks.

So how do I adjust the overall recorded volume level?

Are you talking about the -…+ gain slider on the Track Control Panel? That does not affect recording either. It only affects playback (but does not change the size of the blue waves until you Tracks > Mix and Render) and export.

To change the input volume while recording, use the Audacity input slider in Mixer Toolbar (the right-hand slider here):

If you want to adjust the balance while recording you have to adjust the input balance, not the output balance, unless you are recording computer playback.

Is the problem now that you are trying to get different songs to sound equally loud?

Perhaps it would help if we understood what you are trying to do. What is the source of the audio - are they tracks on a tape cassette or a CD? How are you recording that source (what input source are you choosing in Audacity)?

I don’t understand why you don’t record it as it is. If it is balanced correctly but at the wrong volume, normalise it without the “independently” box checked. If one channel is stronger than the other, then normalize it independently to correct the balance.

If the track you balanced at -1 dB is too loud, use normalize again on that track, choosing a lower dB (greater negative number) and with “independently” unchecked.


I will try this in about 2 hours, when I finish recording another block of titles. Would it make any difference if I re-record a new track with a value different from -1?, rather than normalizing twice? Can I use fractions, such as -2.25? What number would you suggest, assuming (this seems like the logical place to start?) the working file is +5.5 dB over target value?

[Input volume slider is greyed out, and the help file says it’s because it’s a Mac and to use the Midi app, which I described still did not appear to work.]

What I am doing is this: I have my classical music collection on a stand-alone DVD recorder with hard drive in my home entertainment center. The unit is old and going to die soon. I need to get the recordings into my computer so I don’t loose my entire collection. I now have an Oppo into which I can plug an external USB hard drive with my music collection.

I’m playing and recording in real-time each track (or several tracks which I then select individually and save, saving as flac). The input is via the digital audio in on my 27" iMac.

All of my about 300 titles were recorded off FM radio, and the volume is comparable throughout. Except for this one title that is proper volume in the Left track but is 5.5 dB low in the Right track. Thus I am needing to increase right channel dB by 5.5. But the normalization, while making the tracks equal on L and R, also increased the volume overall. I’d like to make it so it sounds about as loud as all my other tracks.

DVD recorder with hard drive

We live on model numbers.

Back to my initial post, the third option is to split the left and right, Effect > Amplify the right channel by 5.5 dB and then recombine them.


The unit is a Panasonic DMR-E85H.

I just did kozikowski’s suggestion. I increased the right track by 5.5 dB then saved the file as flac. However, the final product is still as loud as the first attempt described in my most recent previous post, but the wave form looks like the adjustment took. Is it possible that, even though I’ve established (by ear, centering the audio while playing it in the home entertainment center) that the right channel needs +5.5dB, that I need to enter a number larger than 5.5 in the stereo split track?

I won’t be able to follow up with any suggestions until tomorrow. Thank-you and Gale for your helps.

I want to clarify something. When I increase the gain and then play the file in Audacity, the right channel sound on the computer’s internal speakers does increase.

Am I missing a step? Clearly splitting the track and increasing one of the gains is not enough. I need to do something before I export the file as flac, somehow re-record the recording. Am I thinking clearly, and what procedure in Audacity could I use?

I increased the right track by 5.5 dB then saved the file as flac.

Missed a step.
Drop-down Menu > Make Stereo Track.
Then the blue waves should match and the export should be correct.


Although there’s a mix and render command (which mixes down the selected tracks to one with regard to the gain and pan settings), it shouldn’t be necessary to do this prior to the export.
This is done automatically when exporting a file.
So you say that the center is still slightly to the left when listening over the home entertainement system - although the gain for the right channel is now the same as for the left one?
This may well be, because a single high peak determines the overall gain and it says scarcely something about the perceived loudness of a channel. The RMS value is in this preferable because it takes the whole signal into account.
Even better would be a value that is adapted to the psycho-acoustical loudness curve (Like the replay gain value).
Here’s some code which you can execute within the Nyquist Prompt (in the effects menu).
Use it on a Stereo track.
It returns the peaks - the same value as it shows up in the amplify effect, but negative and for both channels.
The means are equal to the DC-offset (which is removed by the normalize effect)
The RMS values tell you how the energy is distributed among the two Channels. If the difference is a big deal greater than the difference of the peaks, you will most likely see why the balance sounds off the center.
The RMS value is always a lot smaller than the peak (unless it is a square wave you’re analysing).

;; stats
(defun sigma(sig)
(biquad   sig  1 0 0 1 1 0))
(defun last-smp (sig)
  (sref (sound sig) (/ (1- len) (snd-srate sig))))
(defun stats (snd)
  (let* ((peak (peak snd ny:all))
         (mean (/ (last-smp (sigma snd)) len))
         (sig (diff snd mean))
         (rms (sqrt (/ (last-smp (sigma (mult sig sig))) len))))
   (list (linear-to-db peak) (/ (round (* 100 mean)) 100.0) (linear-to-db rms))))
(setf stats-l (stats (aref s 0)))
(setf stats-r (stats (aref s 1)))
(format nil 
"Peak left channel:  ~a dB~%Peak right channel: ~a dB~%
Mean left channel:  ~a~%Mean right channel: ~a~%
RMS left channel:  ~a dB~%RMS right channel: ~a dB~%" 
        (car stats-l) ( car stats-r)
        (cadr stats-l) (cadr stats-r)
        (caddr stats-l) (caddr stats-r))

Could you post the results for your recorded track?

Just to clarify, there is no need to Make Stereo Track before export.


Forget about re-recording. You have already said you cannot change the balance while recording.

Any of the following would work, having recorded the file with the right channel too quiet. If they don’t work you may not be doing it correctly.

  • Track Drop-Down Menu > Make Stereo Track (if have split into left and right). Then Effect > Normalise, and choose a level lower than -1. Put a check in the “independently” box. If the file is already correctly balanced, uncheck “independently”.
  • Track Drop-Down Menu > Split Stereo Track. Select the right channel and open Effect > Amplify. Write down the value that “Amplification (dB)” says, then press Cancel. Select the left channel and open Amplify. Type into “New Peak Amplitude (dB)” the negative of the value you wrote down. For example, if you wrote down “6.2”, type “-6.2” (without quotes). Press OK. Now you have both channels balanced at the same peak level of -6.2 dB. Does that sound more like what you want?
  • Track Drop-Down Menu > Split Stereo Track. Press the Play button. Adjust the -…+ gain slider on each track until you get the track sounding as you want it - balanced and not too loud. Look at the green playback bars in Meter Toolbar so both bars get to about -6 on the scale in the loudest part. Don’t let the red hold lights at the end of the green bars come on. If they come on, turn the -…+ sliders down a bit. Then export.


Thank you all for your help and input. I’m going to call this a success. First:

Robert J.H. : Way over my head! But cool and well written. :wink:

Gale: I tried the middle of your three bulleted suggestions. The preset values were 10.9R and 10.7L. For future reference, should not these values be equal? I wrote -10.9 in for the left channel value, but when played in my HE system, the left still was louder.

No matter really. In the light of a new day, I would say the earlier suggestion of split stereo track, enter 5.5 in the right channel gain, then export works well enough. Strangely (although I think Robert’s explanation about the RMS values may explain this), the announcer’s voice introducing the piece is somewhat louder in the right channel now, but the music sounds balanced.

I think I might request the piece be played on the once weekly request hour in the hopes that their original is in good shape and I can get a better recording. FYI, the piece is Elgar’s Elegy for Strings, running just under 5 minutes for the Academy of St. Martin in the Fields version. A very mellow piece indeed.

Didn’t you get my code to work? That’s a pity.
Maybe you’ll give it another try. Just copy the code, select the stereo track,open the Nyquist Prompt, paste the code and click or press OK/Enter.

When the to RMS values are virtually identical then the pan is centered in average and not based on a single drum hit or so.
The peaks of 10.7 and 10.9 dB that you’ve mentioned are practically identical.
The tolerance is most likely much higher - often even 2 or 3 dBs won’t alter the pan position much. It depends on the actual frequency content (and the RMS values of course).
I wonder how the results from the code would be for a track that you perceive as perfectly balanced via your H-E-S - this could give a clue for future adjustements.
Anyway, that’s only my personal curiosity.

While I appreciate the efforts you have made to help me, I would need a day or so to educate myself about audacity just to understand what you said. Also, for some reason, the Nyquist stuff never loaded when I installed my V2.0.2. I see I have a folder called Nyquest. But until I unchecked Nyquest (somewhere when I was looking over preferences), every time I started the program, it told me I don’t have the Nyquest something installed.

It’s really too much work for something I’m okay about as is.

No the values will only be equal if the peak amplitude of each channel is the same. In this case they are nearly the same. Given the piece of music (assuming there are no loud click or bangs in the recording) it is surprising that a recording with balanced peaks should still sound so unbalanced.

For another way you can find the rms or average sound level, split the stereo track, select one channel, then choose Analyze > Contrast and press either “Measure Selection” button. Then repeat for the other channel. Alternatively, you can guess the rms from how tall the light blue
part of the waveform is.

Since the current Audacity version is 2.0.3, why not install that into the same folder then it will correct that Nyquist problem. If you don’t correct it you won’t be able to run most of the effects underneath the divider in the Effect menu.


Thanks Gale. I really don’t want to put any more time into this. There is something funky about the file, and I’ll request they play it again so I can get a new recording.

I love Audacity but I have an annoying complaint when the program starts.

I have my audio balance set to a specific setting to match my speakers:

L: 63
R: 100
C: 100
SUB: 100
RL: 100
RR: 100

Whenever I open Audacity it resets my audio playback settings to this:
L: 100
R: 100
C: 100
SUB: 100
RL: 100
RR: 100

This is VERY ANNOYING…I have created a special shortcut to get to the playback settings to switch it back to L:63 from L:100 (after Audacity starts).

How do I DISABLE Audacity from making these resets to my audio settings ??? ANNOYED !