Can Audacity Remember a Microphone?

Is there a way to obviate the necessity to select a microphone every time Audacity opens? I only use one mic with Audacity and it gets a little bit onerous to have to select it in preference to the built-in mic which seems to be the default every time Audacity opens. I tried to fool around in Audacity Preferences>Devices but that didn’t work. Any ideas?

We should find out why yours doesn’t. I’ve used the same USB microphone for centuries and Audacity keeps coming back to it time after time. Is it USB? Which one?

Do you unplug it? That’s enough to reset the Mac preferences. Plug the mic in and then start Audacity. Not the other way around.


Thank you Mr Koz. Although no doubt you are a man of wisdom and maturity, I’m sure you haven’t been around for quite as long as centuries :slight_smile: The one I use is Samson C01UPRO. I do indeed unplug it, because the computer it’s connected to is the only one I have and it’s a laptop so it often moves around with me. I have seen your advice about plug in first then start Audacity on another thread and I do that, but after I do that I still have to select the mic from the drop down menu because it always defaults to the inbuilt microphone. Moreover, Audacity doesn’t always detect the mic at all, and I often to perform the dance of unplug it, quit Audacity, open Audacity go to the drop down menu etc. Obviously for people who have a dedicated machine for voice work it’s easy, but for me, if there’s a way to cut down the number of steps, I’d be grateful to know it.

I can save you one step. You can set the recording device from the Audacity front panel at the little microphone symbol setting.
Screen Shot 2016-09-20 at 08.46.09.png
I’ll try the variations when I get home. You just close your laptop, right? It goes to sleep and then wakes up not knowing what’s going on?

Audacity doesn’t always detect the mic at all, and I often to perform the dance

That’s most concerning. Next time it does that, Apple (upper left) > System Preferences > Sound and see if the microphone is there. If the Mac can’t find it, Audacity will never find it and it means there’s a very serious connection problem.

You might go up to that setting now to see what normal is.

If you’ve been doing this for a long time, the connection (or cable) may be wearing out.


I can shorten The Dance, too. Next time it vanishes, replug it, wait a beat or two for the Mac to catch up to you and Transport > Rescan…


And you can eliminate all the steps by playing Order of Appearance.

Close the laptop and/or sleep with the microphone connected. Then disconnect it.

~time passes~

Connect the microphone first. The USB light may flash while the Mac figures out what’s going on. Wait for it to come on steady (you’ll get a feel for how long that is—usually seconds). Then open the laptop. If Audacity is still running, it should have your microphone mounted and ready. No steps, no dance.


If you have a bad connection, you may never get the USB light when you plug it back in. Try, try again. So that saves a bunch of steps, too. If the USB light will not stay on steady, you are, as the technical phrase goes, in doo-doo.


Thank you Koz, the little microphone setting front panel is the one that I’ve been using to select the microphone .
With respect to sleeping, I always just close the top and open it again. Unless the battery runs out when it’s not plugged in, but that’s not very common.
Next time the behaviour happens, I will look in Apple System Preferences and see if the mic is there, thank you.

Oh if only this had worked, all of my dreams would have come true ! :slight_smile: What happened when I re-plugged in and reopened the laptop is that it gave me an error message (I omitted to record the exact wording of it but I will do so when I get home). I had a look in Apple System Preferences and the mic was detected there, but not in/by Audacity.

If this could be made to work, it would be such an elegant solution to this little first-world problem of mine.

The order that you do things is all important.

When Audacity is launched, it will uses the devices that were used last, if they are available.

If the device that was used last is not available when Audacity is launched, then Audacity will look for an available device and try to use the first available device that it finds.

My Mac has El Capitan. On this version, closing Audacity (or any application) with the “close button” does not close the application. The application is just minimized/hidden. So if I “close” Audacity using the “close” button, and then try to re-launch Audacity, then Audacity does not rescan the audio devices because Audacity is not restarting, it is just un-minimizing (made visible).

To “exit” Audacity (close properly), you must “Quit Audacity” from the Audacity menu. Then, when you restart (“launch”) Audacity, Audacity will scan for available audio devices, and if the device that it used last is available, it will use that.

Beware Mac’s “Reopen windows when logging back in”.
It takes a little time for USB devices to connect. If Audacity is launched before the USB audio device is available, then Audacity cannot use it and will connect to a different device. That “different device” then becomes the “last used” device.

As koz wrote, the order of events needs to be:

  1. The device must be connected and recognised by the operating system.
  2. Then launch Audacity.

OS X provides plenty of ways to mess that up :frowning:

If you do get an error panel, you can capture it. Shift-Command-4 will allow you to draw a box around the message and capture it as a picture. Then send the picture to us. Scroll down from a forum text window > Upload attachment > Browse.

This is a good time to play obsessive. Tell us exactly what happens at the steps. Do we know which Mac you have? I did the tests on a MacBook Pro under 10.9.6.


It’s not OSX that messes that up…

It’s default hardware behaviour for power saving. Better devices signal that they go to sleep. Lesser devices don’t, so the OS isn’t aware they’re sleeping.

Most pro gear never sleeps anyway.

And the problem is even worse on Windows, where you can’t predict how some hardware will react. Some mobo’s don’t wake devices after sleep. Sometimes you can set that behaviour in BIOS/UEFI, sometimes there are no settings.

Besides, have you ever tried setting up USB audio hardware in Ubuntu?


That’s Linux in the wild, right?
No, how hard is it?


thank you Steve

Hi Koz I have a screenshot.
Exact steps :

  1. Finish recording.
  2. Close the laptop
  3. Unplug the microphone
  4. Plug in the microphone again
  5. Open the laptop

That’s how I understood your earlier message about economising on the steps. Maybe I read your message wrong.
Screen Shot 2016-09-21 at 15.30.52.png

It’s OS X that doesn’t exit applications when you click the close button.
It’s OS X that controls power management on a Mac.
It’s OS X that controls USB ports on a Mac.

Where does “Launch Audacity” figure in that?

If you Quit audacity between steps and 2, and launch Audacity after step 5 (after allowing a few moments for the USB device to be enabled by the computer), then Audacity should select the same device that you were using previously.

If Audacity was left open at step 2, then it’s a race between Audacity starting and the USB device being ready. If Audacity wins the race, then it won’t be able to use the USB device. In this case, rescan audio devices (Transport menu), then reselect the USB device in the device toolbar.

Koz, I forgot to mention
Mac book air late 2010 with 10.11.6

Ubuntu is easy. And it’s nice. Everything is laid out for you, most usual apps are included. Good for a first try. And it’s based on Debian, which means there are several other choices in the same family.

That’s behaviour that goes back to OS 4. Even before there was multi-tasking. A program could have several windows open and the close button does what it’s meant to do: close the window.

It’s always been like that and it’s the logical way. I close a document and open another. No need to quit the app.

It’s Microsoft, whose copiers seemed to have a bad day who “invented” the illogical behaviour that a “close window” button should quit a program. That is unusable for any program that has multiple windows open, with some hidden. There’s no way for the user to know he’s closing the last window and there’s no way for the program to know the user’s intentions.

Windows 1.0 didn’t even have that function. Every program could only open one window.

It’s OS X that controls power management on a Mac.

Not really. It’s the SMC. And the System Management Controller follows the USB industry Association’s rules. These used to be clear in USB 1.1 days. They got a little clouded in USB 2 days. And they flew out the window completely when USB 3 was designed.

It’s OS X that controls USB ports on a Mac.

And OSX does exactly what it should do: wake devices that are sleeping.

Only, a lot of cheap devices don’t tell they’re sleeping, so they won’t wake up.

This problem started with USB2, because of ipods and other players. Before, USB power just was shut off when the computer went to sleep. But people wanted to charge their ipod, so more and more hardware manufacturers kept power up. And for power, the USB protocol is one way: the device tells the computer how much power it needs and when it goes to sleep. There’s no way for the computer to tell a device to go to sleep. It’s just not in the design.

This wasn’t a problem for desktops either, as they did no “power save” in the beginning. It wasn’t until labels like “Energy Star” came along, that desktops started saving power. And most of today’s desktops are portables in disguise. Unless they’re “workstation class” or “gaming power house” class, of course.

Besides, most hardware has exactly the same problem on Windows and Linux. That’s why RME, fi, design their own USB chips and have a constant polling signal between interface and computer. There is no other way if you want to make 100% certain that the driver will wake on every Windows config out there. And that’s not to blame MS, but the myriad of hardware configs and the hundreds of USB chipsets out there. Some combo’s just don’t work with some devices after sleep.

And that’s not just for USB, Firewire has the same oddities. I have a video digitizer, fi, that doesn’t work at all, unless it’s connected before turning on the computer’s power. There’s no “hot plug” ability. Fortunately, that manufacturer has stopped making hardware.

With all that said, I have an iMic somewhere. I seem to remember this thing always waking correctly. Otherwise I would have gutted it. So the problem could be with an unsupported install that loaded wrong instructions into the SMC too…
And it could also be this unsupported install skipped an important firmware update…

Both of these could result in this kind of strange hardware problems.

Or the iMic could be fake, or the manufacturer changed suppliers and they put another chipset in it?

I’m 100% certain this isn’t an Audacity problem, BTW.