Building with ASIO support on Windows

Hi folks,

I’m trying to build to add ASIO support on Windows 10 with VS 2017.

I downloaded and built the wxWidgets package OK. And downloaded the ASIO SDK. I added system environment variables for WXWIN and ASIOSDK_DIR.

When trying to build Audacity, I got four failures. The first was unable to load zlib.h for libd3tag project. I looked at the additional include directories for the project, and the one for $(WXWIN) did resolve in the UI to the correct path to zlib.h. I verified by pasting into dir at a command prompt. The other three errors were similar. I think the problem here is that my install paths for these components are under a directory with spaces in its name. I had double-quoted the paths in the environment settings, and dir had no issue with it, but I think VS might have. I went back and changed the paths to use the 8.3 short name instead of the part with spaces, and removed the double-quotes, and that did allow me to build Audacity.

Next problem was that when run, Audacity could not find the wx DLLs. I manually copied them from the lib\vc_dll directory to the Audacity Release directory, and that allowed me to launch the app.

Now that it’s running, though, I do not see ASIO as an option in the Interface Host drop-down in Preferences. Should I? Any idea what I’m missing still?


I think that happens automatically if you build the installer: Missing features - Audacity Support
otherwise, you can copy them manually (as you did, and as I usually do :wink:)

Do you have (working) ASIO drivers installed for your sound card (and rebooted)?


OK, yes, when I copy the built version to my machine with the ASIO driver, it does show up. Yay! and also it allows 96KHz sampling instead of being stuck at 44.1K. Yay!

One problem, though, is that the four tracks that get added when I start recording don’t look correct. They were fine when I was using WASAPI in the pre-built version (but the sample rate was not). Any ideas there?

It has just made the first two channels into a stereo track. It’s a bit strange as a default in my opinion, but you can split that first (stereo) track into two mono tracks after you have recorded, so that shouldn’t be a problem (see: Splitting and Joining Stereo Tracks - Audacity Manual). Of course, if you want the first two channels as a stereo pair, then you don’t need to do anything.

If you prefer, you could add four new mono tracks before you start recording (Tracks menu > Add New).