Building Audacity 2.3.3 is OK,but recording doesn't work

Building Audacity 2.3.3 on Windows 7 is successful. i opened a mp3 file, then starting recording, it created a new track to record, when i stopped the recording, it always poped up a dialog

Does the problem only happen with an ASIO build?

i downloaded the source, built it without changing anything. however the assert dialog didn’t pop up when i opened a mp3 file ,then did append recording.

the assert dialog doesn’t pop up, when i open a mp3 file, then use append record

Where did you get the Audacity source code? Do you know the Git revision number?

At first,I downloaded the lasted version 2.4. (master) from git, built it. The assert dialog popped up whennever I tried to record on a new track. I thought I might be the problem with the newest version. Then I downloaded audacity 2.3.3 from the tag list. It had the same problem.

Does the normal official release version of Audacity work for you?

i installed audacity 2.3.3. and audacity 2.0.0 both on my computer, they all work fine

$ git rev-list --count HEAD

$ git describe –

The assert dialog kept popping up, no matter building the source code by using git clone or downloading a zip directly form github website.

Where did you get that?

The correct GitHub repository for the authentic original Audacity is: GitHub - audacity/audacity: Audio Editor

i did use ( git clone to get the source code.
i followed the instructions

I think it’s a minor bug that “git describe” says “DarkAudacity”.
“DarkAudacity” is a side project of one of the Audacity developers. The problem seems to just be a “tagging” issue that does not affect the code itself.

So the problem was only with commit 11850 ?
Have you tried updating (git pull) and then building?

thank you for replying
I’v built Audacity-2.3.0 today (commit 9128), it doesn’t have this problem. I can record on a new track, and when i stop recording, assert dialog didn’t pop up.
With Audacity-master and 2.3.3, the assert dialog popped up at line1117 in track.cpp DeletionEvent( node );
in DeletionEvent(), QueueEvent(…) causes the assert. i think the assert is about node.first != node.second->end()

Is there a reason why you are building from source rather than downloading the official release version?

What is the commit number?
You can get the commit number from the Git command:

git log -1

(final character is the number “one”)

I need to record on a new track, i finished my recording ,then i want to do appending recording at that current selected point. not at the end of the track. i can do now by recording on a new track, then cut and copy to the position i want to do appending recording, but i do that frequently.i don’t want cut and copy many times,

What is the commit number?

$ git log -1
commit bdcd907b543d43d78a09d771a5a1526d77bf0c37 (HEAD → master, origin/master)
Author: James Crook <>
Date: Sun May 3 09:50:43 2020 +0100
Bug 2409 - Linux: Min-source tarball includes 30Mb of wav files.

I still have the assert problem.

So recording works?

Audacity can record into a track either at the end of the track, or at any time after the end of the track. Overwriting a track is prohibited so it is not possible to record into a track before the end of a track.

thanks you for your replying.
I get the lastest version of source, there’s no assert problem now.

Hi. Any debug assertion will only show when you run the debug build. If you build in release, there may be an underlying error occurring, but it will happen silently. Debug assertions are introduced by the software engineer to check the state of the software at certain points, but they don’t work in a release build (usually at least).