Building 3.4.2 windows with ASIO worked eventually!

I have just spent a long day trying to build from the latest released code and following the instructions I had numerous problems which I won’t go in to. To summarize here are the exact instructions which actual worked using the cmake command line not the gui version.

git clone -b Audacity-3.4.2 --depth 1 audacity3.4.2

cmake -G "Visual Studio 16 2019" -DCMAKE_CONFIGURATION_TYPES=Release -Daudacity_has_asio_support=On -DAUDACITY_BUILD_LEVEL=2 -Daudacity_use_ffmpeg=off -S D:\audacity3-4-2 -B d:\audacity3-4

Two key points are that the most recent “master” code has a linker problem; and the default ffmpeg option in Cmake which is
causes the ffmpeg options to dissappear in preferences including the Library section. Then wav and flac files etc. are not recognised and won’t load.

The projects were then built using VS 16 2019

I’m sparing you the many other attempts which didn’t work!

1 Like

Awesome, thank you! Worked for me. I used the following cmake command line because I wanted a Debug version, and I’m running VS 2022:

cmake -G “Visual Studio 17 2022” -DCMAKE_CONFIGURATION_TYPES=Debug -Daudacity_has_asio_support=On -DAUDACITY_BUILD_LEVEL=2 -Daudacity_use_ffmpeg=off -S audacity3.4.2 -B audacity3.4.2.debug

@roadsterUK, all

My first post, and following my first attempt(s) to build Audacity 3.4.2 on Windows 7 64-bit (primarily to get support for ASIO), so please bear with me!

I’ve tried both the cmake gui and essentially your same cmake command line, but in both cases I’m using “Visual Studio 15 2017” rather than “Visual Studio 16 2019”, and both fail.

It seems to die while installing dependencies from Python (I’m using v3.8.10), but upstream there are indications that it just doesn’t like the compiler it’s finding in the Visual Studio 2017 Community Edition.

I can supply the detailed messages from cmake, but I guess I’ll just get right to the point: is it simply not possible to build Audacity 3.4.2 in the Visual Studio 2017 environment?

Thanks for any info or guidance!

My first post says exactly how I got around issues ( not all of which I can recall now). Essentially I give the command line methodology for obtaining the latest released version of the source code and invoking cmake with an odd extra setting to make ffmpeg included by external reference.

Having done this Visual Studio 2016 opened the project file and built the release version successfully.

This got round any issues with trying to build an alpha or beta version. Also I should mention that I updated Python and conan as recommended in before I tried anything else; and I removed any references to the old version of WXwidgets in command environment variables and as previously installed on hard drive.

I hope these hints help and don’t just confuse!

Having done this Visual Studio 2016 opened the project file and built the release version successfully.

The Visual Studio version nomenclature is annoyingly confusing. You actually built with Visual Studio 16 2019, whereas I’m trying to build with Visual Studio 15 2017, and it doesn’t seem to be working, hence my question.

CMake actually quits on me while sorting out Python dependencies, but upstream of that point it flat out balks at the VS 2017 compiler:

…\conan\helpers\, line 48, in get_conan_compiler_version:
RuntimeError: Visual Studio (19, 16, 27048, 0) is not supported

but for some reason continues with the configuration work, at least for a while.

I’m running a pretty bare-bones version of VS 2017, so I was wondering if anyone else had possibly managed an Audacity 3.4.2 build with a more complete VS 2017 install.

I’ll try a minimal install of the VS 2019 C++ development package and see if I have any better luck.