Bug: 3.2.0 Effects appear then disappear

Windows 10 Version 21H2 Build 19044.1889
Audacity version 3.2.0
Worked normally to start: showed available effects after pressing the Effects button.

After crash due to trying apply Lisp plugin as effect, still worked normally. Uploaded the problem plugin again, replaced the old one with the new one in C:\Program Files (x86)\Audacity\Plug-Ins.

Now ALL effects are gone, yet plugins that once showed in Effects sidebar still show in Plugin Manager. Things attempted:

  1. Plugins that once showed in Effects sidebar still show in Plugin Manager. Tried rescan anyway.
  2. Closed and restarted Audacity several times.
  3. Reinstalled Audacity after removing all files (backed up macros and plugins to separate location).
  4. Deleted the plugin that caused initial crashes.
    Audacity_dbgrpt-7108-20220927T102530.zip (24.9 KB)

“x86” = 32-bit.

32-bit plugins will only work in 32-bit Audacity.
similarly 64-bit Audacity will only run 64-bit plugins.

Currently when you update Audacity you will receive the 64-bit version by default.
(which will not run 32-bit plugins :frowning: )
Thankfully there is a 32-bit version of the latest version of Audacity, but you have to seek it out …
https ://github.com/audacity/audacity/releases/download/Audacity-3.2.0/audacity-win-3.2.0-32bit.exe

Trying to install V3.2.0 in WIn pro 7 “over” V2.4.2. Have both installed to different directories and can run both seemingly ok. Both are 64 bit versions I believe. Effects from older version added to plugin directory of new version (which only had a few) and all come up in manager. The added ones do not show up in the effects section however, only the originals. I saw the comment about only working with 64 bit effects but older version installed in the 64 bit program directory on the drive by default?

Anyway, after reinstalling the 32bit version of 3.2.0 and verifying that the effects manager had all my effects, they still don’t display in the effects drop-down as they do in the early version. Any clue how to fix? Thanks in advance!

There is a hidden folder which survives reinstallation


it contains the files “pluginregistry.cfg” & “pluginsettings.cfg”,
if you rename* those, (to say “pluginregistry-old.cfg”), then restart Audacity,
then you should obtain a fresh start with plugin effects.

[* rename is preferable to delete: gives you the option to revert]

Version 3.2.0 is probably 64-bit (that’s the recommended default version, but a 32-bit version is also available).

Version 2.4.2 for Windows was only available as a 32-bit app.
(The first 64-bit version for Windows was Audacity 3.0.3).

By default, 32-bit apps are installed to “C:\Program Files (x86)”,
and 64-bit apps are installed to “C:\Program Files”.