[Bug] 2.4.2 NOT detecting my sound devices ! [SOLVED]


I updated from 2.3.0 to 2.4.2 and… NO sound devices were detedted ! Reverted back to 2.3.0 and… NO problems. Reupdated to 2.4.2 and… NO sound device detected again !!! Any ideas anybody ?

See : https://www.cjoint.com/doc/20_08/JHbadcFLxTL_4368.gif

Thank you for your help,
Win 10 (64b)

NO sound devices were detedted

What are your sound devices?


Here :
these devices lists are from my 2.3.0 version…


Anybody ?

It looks like you have a super-complicated audio device set-up with those virtual devices. Unless any Voicemeeter experts happen to find this post I doubt that we will be able to help you.

This seems to be more widespread than just with the above virtual devices. I just replied to a similar issue here:

I have several ‘pro’ ASIO drivers installed, but generally only one of them is active at a time.

When the MOTU interface in active Audacity 2.4.2 fails to initialize audio, however, all other programs - Reason 11, Roland Zenbeats, NI Battery 4, NI Kontakt 6 all see the active and inactive drivers with no issues - MOTU, NI Audio, JD-Xi, Realtek, etc.

If I unplug the MOTU interface and only have the native Realtek driver running, Audacity sees it and it starts normally. In the input/output drop-down of Audacity, it shows Realtek and Microsoft Sound Mapper.

I am thinking that Audacity 2.4.2 is having a problem with multiple inactive drivers and is trying to use them-- either isn’t enumerating over all of them to find an active one or has a unique ordering that has changed since 2.3.3.

I uninstalled 2.4.2 and reinstalled 2.3.3 – Audacity started correctly and sees all the active devices:
Microsoft Sound Mapper - Output
Speakers (MOTU Pro Audio) - Output
Speakers / Headphones (Realtek
Out 1-24 (MOTU Pro Audio)

Something in the audio interface/driver/enumeration changed between 2.3.3 and 2.4.2 that is causing problems.

Hi everybody and welcome,

in summary : 2.4.2 is BUGGED ! :open_mouth:

Best regards

The drivers are still installed on your computer, even when you unplug your MOTU.

On Windows, they will all use ASIO by default. Audacity can’t be distributed with ASIO support because the license is incompatible with GPL.

What happens if you plug in the MOTU, then kill ASIO, then launch Audacity (and check that ASIO has not restarted).

I think Audacity 2.4.2 uses a more recent version of PortAudio.

From my experience and the experience of others here, it is showing that 2.3.3r is working as expected and correctly with multiple ASIO/audio drivers.

If it is the PortAudio code, then that the version that was included with 2.4.2 seems to be buggy – how would we get dev to look at this?

Perhaps someone in dev can do a code review of the two different versions and see what changed? Or compile 2.4.2 with the version of PortAudio that was used in 2.3.3r (if compatible).

I would be happy to test a version, if that could be done. Thanks.

I’ve looked up the commit when portaudio was updated:
“142 files changed, with 3,846 additions and 9,566 deletions.”

Which drivers do you have installed? Are your Motu drivers up to date?

Hmm… lots of changes

Yes, all drivers are up-to-date. Windows 10 is up-to-date.

JD-Xi (Roland)
Komplete Audio 6
MOTU Pro Audio
Realtek ASIO
UA-M10 (Roland)

The NI and Roland are not being used at this time. Realtek is for the built-in soundcard. MOTU is the primary one being used.


Do you have those devices? If so, can you determine if it is only the MOTU that causes the problem?

Hi Steve:

Yesterday, Dell Support Assistant installed a new video driver and Windows updates installed Feature update to Windows 10, version 2004.

I then installed a different Roland driver for a device I have access too at my current studio location and Audacity 2.4.2 saw it fine. In addition, I plugged in the MOTU interface and Audacity 2.4.2 saw that. I then unplugged everything, rebooted and only plugged in the MOTU. Audacity 2.4.2 is seeing it correctly.

So, it is possible it was the video driver and/or the Feature update that fixed it.

When I replied yesterday, Windows updates, etc. didn’t show additional updates. Then today… it installed the Feature update. So, at this point. I don’t know what to tell you. Both 2.3.3r and 2.4.2 are working.

If it stops working, I will let you all know.

That’s good news. Thanks for the update.

Hi everybody,

Sorry for the late reply but I don’t receive any email notice about your interventions.

I solved the problem by updating Windows 10 to the current 2004 version.

Many thanks

Thanks for posting the solution guys.
I’ll close this thread as “solved” for the benefit of others that experience the same problem.