Broken Waveform Display (SOLVED)


I’m using ubuntu studio 13.10 and Audacity 2.0.6-alpha but I’ve also tried 2.0.3-1. The waveform is not displayed correctly, most of it is covered with solid color (see screenshot). I can see the waveform best when I minimize the height of the waveform box (see screenshot 2).

Any ideas? I desperately need a solid wave editor and did not find a reasonable alternative to audacity.

Thanks for your help

How strange. This is not a known problem with Audacity 2.0.3 or 2.0.6 alpha.
Is it just the display that is incorrect? In other words, does the track play correctly?

You’re still looking. Audacity is not a WAV editor, but you can use it as one if you know the differences.

It looks to me as you are nuclear-grade overloading your sound channel. Reduce the volume of the sound or audio work before the computer gets to it and try it again. If you’re plugging a Line-Out or Tape-Out of a sound mixer or home amplifier into your computer Mic-In, that will do it. Mic-In on a laptop (for one example) will not manage high level or stereo audio. It will fall over and whimper like yours is doing.



The tracks play correctly and are also recorded correctly, if you scroll in my screenshots you can see that it is not a problem of over boosting or anything like that since some party towards the bottom/end of the waveform are diasplayed correctly.
I guess it might be a problem with my graphic card (amd integrated graphics). When starting up firefox, sometimes similar purple squares show up but just for a second.
Any ideas how to find the problem are greatly appreciated.

I’m inclined to agree, that is what it looks like to me.

Try logging in in “Gnome fall-back mode” (or whatever the Ubuntu Studio equivalent) and turn off all video effects, then log out and back in again in fall-back mode. Then try Audacity.

Fixed. Eventually I managed to find the “additional drivers” menu and changed to a proprietary fglrx driver.
Audacity displays perfect and my computer is not getting as hot as before.
To make it not too cheesy, i get the one display settings popup with every click on the screen brightness key, but that’s another story now.