Both input/ouput of Skype call picked up by Audacity

Windows 7
Audacity 2.1.1
Yapster TM YB100A headset

I’m recording my portion of a Skype call for a podcast but Audacity, rather than just picking up my audio, is recording both myself and the person I am speaking to.
I’ve checked that it isn’t caused by the mic picking up the headphones, so what else could it be? When I check in the Windows properties, the microphone and the speakers are showing up as separate audio, so why would Audacity be grouping them? I’ll make a video to show what is happing exactly if it isn’t obvious.

Thanks in advance.

Yes, don’t use Audacity to record Skype, even only just your side. The specialist Skype recording apps can record each side cleanly to separate channels, then you can edit either channel separately in Audacity.


I’m actually looking to record just my audio, not the other person. I’m trying to figure out why Audacity is accessing my headphones and adding them to the mic.

I probably wasn’t very clear, but Audacity isn’t accessing Skype. At least that isn’t my intention. It should just be recording the audio from the microphone source, but it is also picking up the audio going to the headphones. I don’t understand why? In theory, the only input should be the mic.

As I already acknowledged. And we are still saying, don’t use Audacity for this. Skype greatly manipulates audio input and output to perform as a VoIP client.

As I said, record your own voice to one channel of a stereo WAV using an app meant for recording Skype.

Drag the recorded WAV into Audacity, then use the Audio Track Dropdown Menu to Split Stereo to Mono and then use the [X] top left of the other person’s track to delete it.

Assuming you are actually choosing the headset mic to record from, because you don’t have clean audio pathways when Skype is running. We can’t see your Audacity and Windows Sound settings unless you tell us what they are.

Or perhaps because the headset earpieces are leaking into the mic.

What is the objection to recording with a proper Skype recording app?


It’s not up to you. Skype viciously rips control of the sound system away from you while it’s working. That’s why it’s so insanely successful. It always works.

It doesn’t matter what you selected, there’s zero chance that’s what you really got.

The purpose-built Skype software packages like Pamela “know” what Skype is doing and create their own sound channels and recording services.

There are instances of people who just turned their computer on, ran Skype and Audacity and are producing a successful podcast like that. Those people are digital celebrities.


My reason for not recording with something directly from Skype is I want Stereo, not mono. This is my preference when doing a multiender podcast. Now I’ll find another solution if need be - I’m aware of what’s out there - but right now I’m trying to find out why Audacity can’t seem to recognise the different inputs - headphone and microphone - but Soundrecorder, for example, can.

I appreciate the suggestions, but I’m not looking for a work around. I specifically would like to know why this is happening in Audacity. I would like to know if anyone has had similar experience. I’ve used other PCs with Audacity to record while I speak on Skype, I’ve also other hosts doing likewise, never with an issue. So is Audacity likely confused with this particular soundcard, or is it a simple settings fix?

If that headset mic is stereo, make sure you are selecting 2 (stereo) recording channels in Audacity’s Device Toolbar.

If you want stereo effects on your voice, you can add some reverb in post-production, or add panning, even starting out from a mono track. The advantage of this is greater control than you have while talking live.

To answer that we would need you to say what your settings are in Audacity’s Device Toolbar and Windows Sound. :wink:

Is your aim to record from the headset mic, or some other mic you have not told us about?

If “Soundrecorder” is the Windows Sound Recorder, we can say that only records from the current default Windows recording device.

So if Sound Recorder does what you want, choose the Windows default recording device in Audacity’s Device Toolbar. To do that, either choose MME host with “Microsoft Sound Mapper - Input” as the recording device, or Windows DirectSound host with “Primary Sound Capture Driver” as the recording device.

If that gives you poor quality, try Windows WASAPI host and then choose the microphone input you are using by name as the recording device.

If you are still stuck I suggest opening Help > Audio Device Info… top right of Audacity. In that window, right-click and Select All. Right-click and Copy. Paste here.