Bogus "Automatic Crash Recovery" dialog


I recently downloaded and installed Audacity 3.4.2 - on Ubuntu 20.04.6 LTS. Every time I run this application (including the very first time I ran it), it immediately shows an “Automatic Crash Recovery” dialog.

It shows 1 recoverable project.

  • If I select “Discard Selected” nothing happens.
  • If I select “Skip”, I am able to continue, but the dialog will come back again the next time I open Audacity
  • If I select “Recover Selected”, there will be another dialog, saying that the project has been recovered but I have to save it.
    • But if I do save it, the same “Automatic Crash Recovery” dialog will still come back again the next time I open Audacity

Screenshot from 2024-02-21 21-53-52

My impression is that this is a bug, but I didn’t get any search results about it from github or anything. I guess another possibility is that it is having an issue with permissions in Linux for a filesystem location of which I am not aware…

Would like to know if there is any workaround for this. Or if there is anything more I should do to report it.


This seems to have magically resolved itself during the process of troubleshooting. I might have done an apt update which updated a dependency or something.


  • By inspecting the source code, I found the directory where it stores the recovery files (/var/tmp/audacity-<username>)
  • The filesystem showed the project that kept appearing
  • Then I launched Audacity
  • Then I clicked Discard Selected, which triggered a confirm box this time
  • After confirming, the filesystem showed that the file was still there and Audacity had some kind of -wal copy of it
  • But when I closed Audacity, both the original file and the copy were gone.
  • Now it doesn’t come back anymore (yay)

So I guess that seems fine. Other than, if I click “Discard Selected” I would expect the file to be deleted immediately, so I’m not sure why Audacity waited until I closed the application.

This topic was automatically closed after 30 days. New replies are no longer allowed.