Blue Yeti won't connect

Hi all,

I’ve been trying to connect my blue yeti to audacity/my laptop in general for a good hour now and nothing google is giving me is working. It not only doesn’t appear under recording devices in audacity, but anywhere in my computer. I’ve tried going into my privacy settings, as well as tried rescanning devices multiple times from multiple places.

The USB ports work fine; I use them for other things too and checked with my mouse, which worked in all of them. The blue yeti also knows it’s plugged in as the light goes on. My laptop microphone is on and works fine.

Very much hoping it isn’t broken as I can’t afford to replace it right now, but I’m starting to think that’s the case.

I’m not super tech savvy so all I can tell you about my laptop is that it’s a 2 year old ASUS gaming laptop with windows 10.

Try another USB cable. The light coming-on means you have power but one of the data connections could be broken. If that doesn’t work try it on somebody else’s computer. You shouldn’t have to install any software or drivers, just plug it in and see if “Yeti” or “USB something…” shows up as a recording device.

The most common connection problem is order of appearance. Connect the microphone first and let it settle and then run Audacity. Audacity checks for devices when it starts.

You can make Audacity look around later with Transport > Rescan…

What happens when you plug your analog headphones into the Yeti connection on the bottom?

Screen Shot 2020-10-13 at 14.44.12.png
Make sure the headphone volume control is turned up.

Right-click the speaker symbol on the bottom right of the Windows desktop > Drill down to recording devices. Is there a bouncing sound meter and does it bounce? You can tell which microphone you’re using with the scratch test. Gently scratch the Yeti and any other microphones you may have connected. Only one will be insanely loud.

Totally try the microphone on somebody else’s computer. The Yeti should automatically mount on both Windows and Mac. Macs have a similar system control panel and bouncing meter.

Where do you lose it?