Blue Snowball No Longer On Input Device List

I’m in trouble!!!

I do voice overs professionally (up against a deadline) using Audacity and a Blue Snowball microphone…done a fine job for some time now.

Catastrophy hit today!!! Suddenly the micorphone no longer shows up as one of my input devices, it always did before. I have made no changes whatsoever since everything was set just the way I needed it. Now it just says “USB Advanced Audio Device” which is utterly useless since the recording levels simply cannot be adjusted and it defaults to max levels.

What must I do to get Audacity to recognize my microphone again.

Running Linux Mint 17 which is up to date and also just updated Audacity to the latest version (thinking, hoping that would fix the problem).

Please help!

Try installing pavucontrol (Pulse Audio Volume Control).
Then open Audacity and set the recording input to “Pulse”.
Then open pavucontrol and set the recording input to the one that you want to use.

Just hitting first level maintenance first: Is the microphone still alive? Does it work on another computer? Snowballs don’t need special drivers and they’ll work on your mum’s laptop.

Did you try a different USB port?

Did you try restarting Audacity or Transport > Rescan Audio Devices? If there is anything wrong with the microphone data, Audacity may “forget” about the microphone.

Something changed or everything would still be working.

Do you have access to your mum’s laptop if you can’t get this one to work? I’ve been known to double record important sessions.


Yeah, thanks, I know snowballs don’t need special drivers. However, when Audacity recognized it, it worked way better than now. Tried everything, different USB ports, USB cables, mic works as is but input device sucks! It’s not the mic for sure. Audacity simply cannot recognize it anymore. Will try Steve’s suggestion of the pulse route…hope it works. Thanks.

Tried > everything> , different USB ports, USB cables,

Different computer…


Wish I could, I’m on the road and need to make it work on my laptop…

OK, so Audacity is still not recognizing the Snowball specifically, still shows as “USB Advanced Audio Device”. However, I am now able to adjust the recording level, something I wasn’t able to do before. This really was my main concern. I don’t care how it shows in devices as long as I can configure it for use.

I only did two things in terminal which seemed to do the trick, rather elementary:

sudo apt-get update

and then

sudo apt-get upgrade

Sometimes it’s really as simple as that…still quite curious though why Audacity was suddenly unable to recognize the microphone considering I had not made any changes…perhaps any one of the regular updates to my system somehow led to this event…

Thanks for the help.


Audacity reads the device names from the device drivers. If the drivers are updated (which may occur during a normal update), the name that is provided by the driver may change.
You can see additional information about devices that are seen by Audacity by using “Help > Audio device info”.

Thanks, Steve, for the clarification, I thought as much.