Blank recording, when using USB audio interface

Hi everyone at Audacity forums,

I did not want to have to go so far as to make an account on this forum, and make a specific post about my problem; but I am left with no choice. I cannot find answers anywhere around Google, YouTube, or other tech forums. So here I am, making a specific post to what seems to be a very specific problem. I actually found a similar forum post earlier today (on another forum) - which I will link you to shortly, but a successful answer still hasn’t been made on that thread.

So here is my problem: … When I record on Audacity, through a USB audio interface, I am left with nothing but a blank track.

My USB audio interface is called “Behringer UCA222” :
I am recording with a keyboard.
I am using Audacity version 2.0.5.
I am using Windows 8.1 OS.

What is SOOOO weird, is that I have recorded this way many many times before, and it has worked without any problems. Even just last week, I recorded this way with a condenser microphone and it worked fine. I haven’t recorded with my keyboard in a few months, and when I tried last night it simply wouldn’t pick up a signal. I don’t see why it suddenly wouldn’t work.

Here are a few things that I have tried already:

  1. Changed the “recording device” in Audacity. Yes, I have made sure that I am recording with my USB audio interface.
  2. Installed the USB Audio interface. It is indeed installed, and Windows does not consider it as a generic microphone. It considers it as “Line in”, and calls it by name (Behringer).
  3. Checked if the keyboard is working. The keyboard does indeed transmit into the USB interface, as it has a “monitor” setting, and I can hear the keyboard being played. Obviously some sound is being transmitted from my keyboard to my interface.
  4. Checked if Audacity is recording properly. It seems it is, because it will record sounds when I change the “recording device” to the default “Microphone (Realtek High Definition)”.
  5. Seems that there is sound being transmitted from the USB interface to my computer. I just recorded sound through an external condenser microphone last week, and it records fine.

Obviously everything SHOULD be working. There’s no reason for it not to. Sound seems to be transmitting from my keyboard to the USB interface, then to my computer. And audacity is able to record sounds. Yet it is indeed NOT working.

Here is the similar forum post that I mentioned earlier. This person has the same problem it seems, yet he never actually gets an answer that solves the problem.

I am REALLY hoping that someone can help me with this problem. Is there something I might be missing???
Its always so frustrating when you know something should be working, but it just isn’t…
Thanks everyone for reading!

What is the keyboard, and how is it connected to your computer?

That is a very old version. The current version (2.2.1) is available here:
I’d suggest that you uninstall the old version before installing the new version.

Try this:
Connect the keyboard to the Behringer interface, and connect the Behringer interface to your computer.
Open the Windows Sound Control Panel and go to the “Recording” tab.
Play something on the keyboard.
Do you see a green meter jumping up and down in the control panel when you play?

Hello steve,

It seems that the problem has been solved actually.
Thanks for recommending me the latest version of Audacity! I must update now! Didn’t even realise how dated I am :smiley:

Anyway, the problem seemed to be with my wires. I have a set of two stereo wires that connect a regular 1/4" socket (for my keyboard), to an RCA socket (for my USB audio interface). They are stereo, but my keyboard only supports mono, and I had the wrong wire plugged into the socket of my keyboard. I found out when I decided to use stereo recording on Audacity, and found that everything was being recorded in the lower stereo-track (which is why it wouldn’t record at all for a mono track). Anyway, problem is solved now. I am so happy!!!