Black screen in editing area upon opening and while recording

Hey all,

Running 2.4.1 on Pop_OS 20.04 (so, basically Ubuntu 20.04 with Gnome) but had the same issue on 2.3.3, starting this week. I last opened Audacity on Sunday, June 14 and had no issues. Today when opening it, I was greeted by a black screen in the “editing” region if you will, and when I try to record, it records just fine, but I can see no waveforms, just entire black.

The 2.3.3 was installed using the Ubuntu release, and 2.4.1 is the Flatpack found in the Pop_OS software store.
Link to image of what I see on Dropbox.

Any help would be greatly appreciated!

Have I got this right:

You were previously using Audacity 2.3.3 on Pop_OS 20.04 (based on Ubuntu 20.04) and it worked fine.
Then, without knowingly making any changes (other than routine updates), a problem (black track panel area) appeared in Audacity 2.3.3.
You tried updating Audacity with the Flatpak Audacity 2.4.1 version, but the problem remained.

I’m trying to get a clear picture of what’s happening as we are receiving multiple reports of graphical issues with Audacity on Ubuntu 20.04.

You are entirely correct. 5 days ago on 2.3.3 we were all good, then when I opened up something broke causing the black screen I mentioned.
I uninstalled 2.3.3 and tried reinstalling it with sudo apt install, which didn’t fix it. So, uninstalled again and went for the flatpack of 2.4.1 available in the Pop software store, which still had the same issue.
A notable condition is that my top bar in gnome also “flickers” while Audacity is launching.
And, if I import audio (say a .wav for example) then I get a “zoomed in” view of the audio that doesn’t move. In other words: if I try to move through the timeline, the time stamp moves and playback works, but the waveform remains stationary.

See my post here:

Alright, thanks for the update! I look forward to (hopefully) having this resolved soon once the wonderful folks making Audacity can sort it out.

Trying to use ocenaudio as a stop-gap for now. =/