Big Sur 11.3 and Audacity 3.0.0

Guys, great work on Audacity 3, but something is not as it should be, and I’m not sure what I can do to help give you what you need to debug.

I work on a number of simultaneous singing tracks for a virtual choir. Visually the tracks all look fine - no clipping and no red lines on the screen. I export it (have tried differing formats all with the same result) and when I import it back into Audacity, it is clipped and flattened… with red lines all in the louder parts.

This didn’t happen in 2.4.2, of that I’m certain…a WAV file reduced before export remained reduced when imposed into Audacity again. What’s changed?

(To explain, I create a virtual choir. I work on it voice part by voice part, export the voice part as a WAV file, and then bring all the WAV files together to make the choir, so this is a major issue to me.)

Are you exporting the mixed voices, or each voice individually as WAV files?

If you are exporting the mixed voices, what do you see on the Playback meter (does the red clipping indicator come on) when listening before exporting?

– Bill

The WAV files show no red and no red on playback. I’m mixing four or five voices together and then exporting that as a single WAV file. In 2.4.2 I would select the voices and with Allow clipping turned off, use Amplify to reduce the voices. Amplify would default to the negative settings to stop the clipping. That does not work in V3. So I have to have a trial and error to reduce the amplitude before I can export it.

Also in 2.4.2 when exported with no clipping, the WAV file when imported still had no clipping. Not in V3 - for some reason the WAV file is amplified on import.

I don’t understand the above. If Amplify suggests a negative value, then the track is already clipped.

Are you selecting each track in turn and applying Amplify, or selecting all tracks?

I’ve tried this at home and I can’t see any difference in behaviour between 2.4.2 and 3.0.0.

– Bill

This is why I say I’m not sure what I can provide to help this get sorted.

Simply put, in 2.4.2 I used to use Amplify to reduce each track so there was no clipping. It worked if I used it on a single track or selected across all the tracks. I exported the WAV and when I brought it back in to Audacity again, the WAV file was still usable, exactly as it was when exported.

In v3, I do exactly the same, but on importing the WAV file, it’s clipping badly on the louder sections.

I can’t see why this would be. I don’t even know if it’s a bug or simply a setting. But it does not make sense and is very time consuming to resolve.

I will remove v3 and load 2.4.2 today and do this again and see if I can provide any insight to it.

I still can’t understand this. As I said before, the track was already clipping (how did that happen?) in order for Amplify to suggest a negative value.

If you have multiple tracks selected and apply Amplify, it looks for the value that will set the loudest track to have a peak value of 0 dB and applies that value to all tracks. So you will usually have one track that has a peak value of 0 dB and the other tracks have peak values below 0 dB.

You can have 2.4.2 and 3.0.0 installed simultaneously. Just rename one of them - for example rename the 3.0.0 version to “Audacity 3”. Then you can go back and forth trying the same steps with the same audio on both versions.

– Bill

May I suggest a slight alteration to your workflow:

  1. When you are happy with your project, File > Save; then
  2. Tracks > Mix > Mix and Render
  3. Edit > Amplify, etc.
  4. File > Export > Export as WAV

I hope this helps. :smiley: