So I got my hardware done. Samson condenser mike, Neewer power supply connected to my computer. It works kinda but when I record something playback is really fast. All I want to do is recite ‘A Christmas Carol’ to leave for my grandchildren. Maybe add some background sounds and music. I must be doing something wrong. It’s confusing.

Setting the Audacity project-rate (bottom left corner) to 48000Hz, rather than the default 44100Hz, is worth a try, before making new recordings.

If that doesn’t work I’d try Audacity’s free competitor OCENaudio which is aimed at beginners …