Beginner: Error 9986...Help :)

Hi all:

Just installed everything fine and was all set to record from cassette when the following error message popped up:

Error opening recording device
Error code: 9986 internal PortAudio error

I checked audio settings in System Preferences to make sure everything was aligned with Audacity settings and still no-go. Cassette device is recognized in Audio MIDI setup app.

Mac OS 10.13.3
Audacity 2.3.2

Any help would be appreciated. Thanks!


Sigh. Is this one of those $30 cassette-to-USB devices? Does it show up in System Preferences > Sound as “PnP Audio Device”?

Lots of people have trouble with those. Try this. With Audacity open and the cassette selected in the Device Toolbar, start the cassette playing then press Record in Audacity.

– Bill

Hey Bill:

It was a gift, so I don’t know the price but, yeah, it seems not exactly high end. :slight_smile:

It DOES show up in in Sound Preferences, though, and I was able to actually record 5 minutes of stuff yesterday before it conked out.

Any recommendations for a higher-end device?

If you’ve already got a “normal” cassette player with either “Line out” or “Aux out”, then you could use a USB sound card. One of the cheapest reliable ones that gets mentioned regularly on this forum is the Behringer UCA-202 (about $30).

I am getting this now with a Behringer USA202. It had worked before and I thought I had it all working right, but I must have screwed up something

I am running 2.4.2 on a macbook air running OS10.14.6 Mohave. When I started typing this I decided to try quitting and restarting Audacity, and doing that made the 9986 error stop and the recording start, although I am not getting output from the internal speaker on the Mac, although as far as I can tell it is turned on and selected in preferences. That must be comething else I screwed up, but I wanted to report that rebooting Audacity can get the recording started. Getting the audio restarted is another days problem.

Thanks for your prior help.