backing track present on new recording track

Hi I have downloaded an MP3 piano backing track (track 1) but when I try to record voice on another track (track 2) the piano track records on it as well as my voice. How can I prevent this?

see …

Hi Trebor. I tried that but it doesn’t work. I still get both the backing track and the voice on the new track. Is it something to do with the backing track being an MP3 format?

Is it something to do with the backing track being an MP3 format?

No. Audacity doesn’t edit MP3. It converts everything to its own internal sound format.

What do you have for a recording device? You have to be recording directly from your microphone or soundcard, not a made-up, fake device such as Stereo Mix or What-U-Hear.

Screen Shot 2018-07-19 at 04.02.13.png
You get crosses like this if you like to record internet audio. The settings for that are different from recording overdubs.

These are the settings you don’t want.


The recording device is a cardiod microphone plugged directly into the PC mic input. It sounds fine. The backing track is a piano track laid down by a friend and recorded in MP3 format. If I select “Other tracks while recording (overdub)” it records the microphone onto the vocal track but also the backing track as well. If I deselect “Other tracks while recording (overdub)” I can hear the mic through the headphones but not the backing track.

How are you listening? Many laptops only have one connection for everything.

What’s the cardioid microphone?


Not a laptop, full size tower PC with quad core processor and Realtek HD sound card. Microphone is a condenser type Studio Model BM750. Undoubtedly made in China. The sound quality from the mic is actually better than expected.

I can hear the mic through the headphones but not the backing track.

That step right there is wrong.

You are not supposed to hear your microphone at all during overdubbing, just the backing track.

If you click Overdub and Playthrough both, you should hear the backing track and your own voice with a delay or echo.

If your voice in this problem appears perfect, then your soundcard or other service is “helping you” somehow and providing unexpected sound pathways.

There’s zero doubt in my mind that whatever setting is doing that is also crossing the pathways and double recording the backing track.

I’m going to be fuzzy with this because I’m not a Windows elf. I just know what several of the “normal” problems are. We should wait for an elf that knows how to manage the devices and drivers in Windows.


Possibly it’s the sound leaking from headphones (via air, not wires) being picked up by the microphone.
If that’s the case, the recording of backing-track on the overdub will be quiet & tinny,
(like the sound you hear when being next to someone who is wearing headphones).

What else do you have running with sound services? Games, Skype and Chat come to mind. Skype is famous for taking over your sound while it’s running. Restart the machine and don’t let anything else start.


Nothing else running on this machine Koz. To be clear in my mind (please let me know if I’ve got this wrong) I understand I should be able to record track #1 (backing track) then record track #2 (voice track). So track #1 should only contain the backing and track #2 should only contain the voice. If I have this right, when I am recording track #2 I should hear track #1 in my headphones but it should not re-record the backing track #1 onto track #2. However it is re-recording track #1 onto track #2 along with the voice and it’s driving me nuts! All ideas and suggestions gratefully received.


In addition, when you’re simple overdubbing, you should not hear your own microphone, just the backing track. That’s what’s ringing alarm bells.

How are you listening?

We never got an answer to that. Where are the headphones plugged in?

It’s rough finding any information on the microphone. I see a cable with XLR3 on one end
Screen Shot 2018-07-20 at 05.24.29.png
and a plug on the other end to fit in the Mic-In of a soundcard. Is that what you have?

Does your soundcard look something like this?

…and the microphone is plugged into the pink or red socket?


I don’t think this problem is with the microphone as the duplication of the backing track onto the following track occurs even when the microphone is not connected. If it of any help the duplicated track is recorded slightly louder than the backing track.

If it of any help

What would help is for you to answer the questions. We have to build your machine in our imaginations and detailed descriptions of your system are valuable—even they seem to have nothing to do with the problem.


OK, the machine I have Audacity installed on is running an Intel Quad core central processor at 2.83 GHz with 3.23 GigaBytes of Ram. It is running Wndows XP, Service Pack 3. The sound card section is Realtek HD and is built into the mother board on this machine. The sockets are at the back of the machine and are the bog standard blue, green and pink/red. I plug the headphones into the green socket. The mic has a 3.5mm stereo jack which I plug into the pink/red socket. When I record with the mic unplugged I can hear the backing track through the headphones as it duplicates onto the second track.

Thanks for the details.

When I record with the mic unplugged I can hear the backing track through the headphones as it duplicates onto the second track.

I don’t know where to go with this outside of waiting for an experienced Windows elf.

Widows machines have no natural connection between playback and recording. You are intended to listen to internet sounds, machine warning tones or maybe CD playback. As a separate task you can record your own microphone. There is no record the internet or duplicate a CD by recording it. All the people doing that have intentionally set up special software, services, devices or pathways to cross Playback and Record. Again barring a failure somewhere, your machine must have one of those crosses.


From the Audacity Help menu:
“Help > Diagnostics > Audio Device Info”.
Save that info (there’s a “Save” button) to somewhere convenient, then attach the saved file to your reply (see here for how to attach a file to a forum post: )

What is your (complete, exact three-section - see Pink panel at top) Audacity version number; where did you get Audacity (and if not from the Audacity Team’s download site, get the most current version from there).

During an overdubbed session, do a screen grab. Press the PrintScreen button toward the top right of your keyboard. Open your favorite painting program (Microsoft’s Paint should be installed) and paste the contents of the Clipboard (pressing the CONTROL key and the v key should probably work). Save the resulting image and attach it to a reply to this thread (just below the Reply pane is a tab marked “Attachments” - that’s where you will attach the image).

Just as a sanity check, in a non-overdubbing session, with no other tracks present, record a test track with your microphone into a mono track - just count to 10 or whatever (non-musical). Export the track as a wave file. Close then reopen Audacity and import that wave file and try to overdub using that as the backing track (just vocalize some scales so that it will be easy to distinguish the two tracks).

I can’t imagine that it should make any difference, but… go to Preferences (menu Edit> Preferences) and open the Import/Export pane and make sure that you have “Make a copy of uncompressed audio files before editing (safer)” ticked as opposed to the “… (Faster)” setting.

And, as long as you’re in Preferences, go to the Recording pane, do another screen grab so that we can see how that set up. I doubt that it will help us any but, as long as you’re working this hard, also do a screen grab of the Devices pane. Attach them both.

I suspect that we can get this sorted out, but it will probably take patience and a painstaking attention to detail to figure out just what’s going wrong - collectively, we’ve had many years of experience troubleshooting Audacity, but none of us have seen this before.

Hi Edgar
Problem solved. The Realtek control panel has a stereo mixing facility on this version for recording. Simply muting this option has solved the problem. Unfortunately Realtek do not offer a manual for this application neither is there a help file available. Many thanks and regards to all who replied and offered suggestions.