background noise

when recording from my sound card or recording what I hear through my pc speakers I notice I have unwanted sound. I notice this easily between wave forms the sound bar shoud be flat and thin whereas mine is thick resulting in unwanted sound. I’m thinking this is an internal problem that might be resolved with a change in setting but I am unaware of what change(s) to make, because I think I have tried them all. My issues only started a few weeks ago and before this all worked as I liked. Yes I am aware I can remove unwanted sounds throught “effects” and “noise reduction” but since this is a constant issue I would like to know if there is an internal setting I may change ???
I have Windows 11 Pro / Audacity 3.2.0

It is possible that earlier you were recording from “stereo mix” or “Speakers (loopback)” (WASAPI) and that now you are recording from a microphone and picking up ambient noises from the fan, for example. If you are running 3.2.x, you can do View=>Toolbars=>Device Toolbar to see at a glance your input and output selections. (This toolbar was recently hidden to provide more room for the other displays).