avformat-55.dll is being ignored

I am using Audacity 2.3.3 on Windows 10 Home (64 bit).

When I want to open an aac file, I am told that FFFMPEG is missing.

So I followed the instructions from https://manual.audacityteam.org/man/installing_and_updating_audacity_on_windows.html#winff and downloaded the zip archive and extracted the avformat-55.dll to C:\Program Files (x86)\Audacity\avformat-55.dll. I then go to Options → Libraries and locate the avformat-55.dll in that folder.

After clicking “OK” nothing happens. The library is not accepted. AAC files can still not be opened.

Is this a bug or what did I do wrong? Please advise and thank you very much.

Shut down Audacity and restart it.
Then go to “Help menu > Diagnostics > Show Log”
Save the log somewhere convenient, then attach it to your reply.
(See here for how to attach a file to a forum post: https://forum.audacityteam.org/t/how-to-attach-files-to-forum-posts/24026/1)

Thank you for pointing me to the diagnostic log. I analysed it myself (it is in German, anyway), found the problem and solved it.

I feel stupid as well as a little bit angry. Fact is, you don’t have to copy avformat-55.dll into the program folder, but ALL THE FILES contained in the ffmpeg zip file (that’s embarassing), but that is mentioned NOWHERE (this makes me a little bit angry).

Anyway, thank you for your fast solution. And to all the folks with a similar problem: download the ffmpeg zip file and extract ALL THE FILES contained within it to the audacity program folder. Then the library needed for aac files will be detected.

Thanks again!

I guess that when you viewed the page Installing and updating Audacity on Windows - Audacity Manual you missed the bit that says:

For full instructions please see > Installing FFmpeg for Windows> .

In the “full instructions”, it recommends downloading the ffmpeg-win-2.2.2.exe file. When you run that, it automatically installs all of the required files in the right places so that Audacity can find FFmpeg automatically.

At least you are up and running now, and hopefully this thread may help others that have similar problems.

You are correct. I downloaded the recommended zip file, but I also missed this:

“Extract the entire contents of the downloaded ZIP file”

So as usual, “reading helps”. :wink: