AutoTune with GSNAP missing left hand waveforms

  1. GSnap visual representation of pitch source and tuned missing waveforms:

Just install the GSnap plugin and it is working except the left hand side of the GSnap settings window does not show ANY before and after waveforms correction hints. (red and green waveforms)
I have tried selecting the 12 the buttons (so all green = on I assume)
The left hand part of the image looks a rotated keyboard. Maybe this allows you to limit the enabled snap notes.
But with all selected NO waveforms like the user manual shows. I attached 2 examples of my results vs
1 image from the GSnap user manual.

Using Windows 7, Audacity 2.1.2, GSmapwin32 (dll of 5/14/2015)

Any advice would be appreciated.

  1. Had any had any success with the GSnap MIDI input snap? Just want to know before I buy a laptop interface
    since I saw one post saying it might not work on some systems.
    gsnap user guide shows waveforms on left side and highlited text definition at bottom of image.JPG
    12 buttons X.JPG
    12 buttons on.JPG

I just learned that the part of the display next to the place the waveforms appear where the piano keys are show is also controlled by the Set A Scale selection
that puts and X on the keys (notes) that will not be tuned to.

I checked my test signal with Audacity Analyze and I clearly have a C Major scale but no waveforms.
I have hacked 2 notes of a piano test signal to be out of pitch + or - 3-4%.
I tried C# and B, even F, nothing but it is trying to auto tune but not making large key changes. No waveforms. I noticed its not really changing keys (e.g starting with a C and going to a F). Its doing slight pitch adjustments (maybe 5%)
so maybe this is the error I need to find. Tts not making big changes and the minor minor ones dont result in waveforms.
Then I changed to factory defaults:A Cromatic which puts and X on C D#, F G and A#), but, still starts tuned result with a C.
So then I isolate 1 note, say F. Then X out F and other keys say except A. AutoTune, no pitch change.
Maybe Audacity waveform shows processing happened, but only volume was reduced.
After auto tune to A.JPG
F note before.JPG

Audacity does not support MIDI features (or features that depend on MIDI support) in VST plug-ins.
Audacity’s MIDI features are very few - basically just importing, exporting and trimming MIDI tracks (not even play or record).

Ok thanks for the input.

Found my error in the above case: Threshold setting was not high enough. Changed it to 600 cents and got the change from a single C note to F.

Still no waveforms showing next to the small keyboard left.

I wondered if waveforms only show when using GSnap as you record but I did use
GSnap during recording, it did AutoTune but still no waveforms.
I tired asking the the GSnap author in an email but no response. Must be a bug.

Not with Audacity.
Audacity does not apply effects while recording. Audacity is a tool for editing and processing “off line”.

As Steve said, Audacity does not apply effects while recording. If you have the effect enabled, it may seem like it applied during recording, but it didn’t.

As you have observed, there is a known bug that Audacity processing halves the volume even when the track is mono as intended. This is because Audacity is setting GSnap to stereo and then mixing in a silent right-channel for processing, so resulting in half volume in mono. So it looks like it would be better to duplicate the mono track, use the Audio Track Dropdown Menu on the upper track to “Make Stereo Track”, then when you are done, use Tracks > Stereo Track to Mono.

You may get on better with Autotalent for Windows (VST) from which does not reply on MIDI tuning.