AUP3 corrupted project

Unable to read Audacity AUP3-project - “Audacity failed to read from a file in H:”
OS: Windows 10, version 1909
Audacity Version: 3.0.2

Here’s what led to the issue:
I opened 10 different projects simultaneously. I’ve done this in the past and hasn’t ever been an issue, but this time, one of the projects opened with a warning message that read something along the lines of “The project was not properly saved the last time it was closed”. I clicked OK on this warning message but this crashed (froze) Audacity and eventually Windows displayed “Audacity is not responding” and I clicked “Close the application”. This immediately terminated ALL of the Audacity instances that I had opened. After that, I tried to re-open the file that gave me the warning message. However, this time it displayed a “file error”-message, “Audacity failed to read from a file in H:”. (please see attached screenshot)

The project now only consists of a single mono track, around 5 minutes long, but it doesn’t contain any audio. Worth mentioning is that when I initially opened the project (when I received the first warning message that the project hadn’t been saved properly) I could see all of the tracks in the background- so I think it’s safe to assume that it was working up until the crash happened.
The project probably has +10 stereo/mono tracks (well, it did before it got corrupted). The project file size is still quite large, 1.48 GB, so hopefully the information is still there.

Can someone please let me know if it’s possible to restore the project? Lmk if there’s any more information that you will need!

Best regards

  1. Shut down Audacity
  2. Copy the project to your Desktop
  3. Launch Audacity
  4. “File menu > Open” and select the copy of the project on the Desktop

Does that work?


Thank you for your prompt reply!

Unfortunately it does not help. I receive the same file error message, but this time it’s on my C: drive, instead of H:

Ensure that Audacity has permission to read / write files on your computer.
(This may help:

Where is H:?

Is that a cloud drive? Audacity doesn’t get along with network or cloud drives very well.

It doesn’t Hindenburg straight away, but Audacity becomes unstable and more likely to lose work.

Some jobs do fail. You can’t for example, do any job that involves tight integration between Audacity and the drives. Musical Overdubbing comes to mind.

Home networks can have problems, too.

Network drives are sharing their connection with Audacity and Audacity doesn’t understand network collision detection, routing management, error processing, and resend scheduling.

Companies are doing everything possible to make you think clouds are just like local drives, but they’re not. In one extreme but real example, most of your show may have gone to the physical drives outside of Denver more or less directly, but some of it may have gone by way of Tegucigalpa because of network congestion.


There are a lot of settings that I have turned off here. Is there are particular setting that needs to be on? Still, I’m not sure if this is what’s causing the issue. I work a lot with Audacity and have never ran into this issue previously. I’d expect that if it was actually a permission-issue, then there’d be more projects that I wouldn’t be able to open?

Hi Koz, thanks for your input! H: is a physical local drive (3TB), however, all files that are stored in H: are synced to my NAS. All files are stored locally and then synced, so I think it should be okay.

My C: drive is also a physical & local drive, SSD (128GB).

Best regards

I tried to open the file from another computer, it’s running the latest version of Audacity, version 3.0.3. I was unable to open the file, it gave me the same error message, however, it did give me a bit more information. Please see attached screenshot and information below.

    "timestamp": 1628244545,
    "event_id": "8bc3c0399b2f0c49a7f3e8b988bdaa2f",
    "platform": "native",
    "release": "audacity@3.0.3",
    "contexts": {
        "os": {
            "type": "os",
            "name": "Windows",
            "version": "10.0.19041"
    "exception": {
        "values": [
                "type": "File_Error",
                "value": "Audacity failed to read from a file in <path>.",
                "mechanism": {
                    "type": "runtime_error",
                    "handled": false,
                    "data": {
                        "sqlite3.rc": "101",
                        "sqlite3.context": "SqliteSampleBlock::Load::step"

Best regards

If you feel comfortable doing so, zip up your aup3 file, post it on a public server, then PM me a link. I’ll take a look at it.

Wow…lucky you.

Rich, I saw your posts on the other thread, and I will reply to it over there.


I am sending you a link via PM, for what I was able to recover from your .aup3 file. It “appears” to be mostly intact, however, there was damage to about 20% of the database - so check it thoroughly - I don’t know why the damage occurred.

I previously sent you the link by PM. It is a zipped file, so will have to unzip it. I have just now sent it again.

A combination of tools including DB Browser, the Visual Studio debug tools along with the Audacity source code. I am a volunteer - I am doing this because I want to learn. Along the way, I discovered there are some SQLite Database repair tools that cost $$, but I currently have no reason to suspect they may have helped in this case; also, they are outside of my budget.

I dont want to be boring, sorry for this, but can you see what is happening in my project too? its the same error.

the link for the project is:

This is a duplicate of

Topic Locked