Audiofire 12 - Most channels missing

64-bit Win 7, 8, 8.1, and 10; Audacity 2.1.1; .exe installer

I have two Audiofire 12 units with the latest v5.8 drivers and v5.8 firmware and I’m trying to get them working with Audacity (and actually Reaper too), but there are several problems. At one time I had these units working perfectly with Reaper on a Win7-64-bit system, which I upgraded through the standard sequence of Win 8.0, 8.1, and 10, and everything continued to work perfectly with each of them. However, the disk eventually crashed taking the configuration files with it and I haven’t been able to get any clean installation it to work right since. I am now using two separate computers to try to figure out what’s wrong: a Win7-64bit AMD system using a TI Firewire chipset and a Win10-64bit Intel system using a Via Firewire chipset, but the problems are exactly the same on both. For that reason I think I simply must have a configuration issue that I can’t figure out.

In a nutshell the issue is this: I am trying to play some existing 24-track Audacity projects but they only play through 2 of the Audiofires’ 24 channels, even though all channels are showing playback activity in Audacity. All channels are un-muted and at full volume both in Audacity and in the Echo FireWire Console. To simplify my trouble shooting efforts I began by only hooking up one Audiofire 12 device. I selected “Surround Sound”, 44.1kHz, 256 samples, and Internal Clock in the Echo FireWire Console. Without even running Audacity itself I looked at the Windows Control Panel → Sound → Playback window and rather than seeing just one Audiofire 12 device it showed two, where one of them indicated channels 01-08 and the other indicated channels 09-12. I tried disabling all other sound playback devices both in the Sound window and the device manager but it made no difference on either computer. I then went back to the Echo FireWire Console and selected “Stereo”. At that point the Sound window displayed 6 Audiofire 12 devices with two channels each. Maybe this is normal and the settings in Audacity are somehow supposed to override this - that I don’t know. I tried reverting to previous versions of the Audiofire drivers and firmware and the Firewire drivers themselves but it made no difference.

I then started Audacity back up and went to its Preferences window. In the “Devices” settings the choices for the Host Interface were MME, Windows DirectSound, and Windows WASAPI, so I selected MME. Among my choices for the playback device were the strange “Analog out 01-08 (AudioFire 12)” and “Analog out 09-12 (AudioFire 12)” devices I mentioned earlier. However, it didn’t really matter which one I chose since the playback only reaches two of the Audiofire 12 channels anyway. At that point I disconnected the first Audiofire 12 device and connected the other one, thinking it might be a hardware problem, but it acted exactly the same way. I’ve also used two different sets of Firewire cables.

So here I am with two $500 Audiofire 12s that I can’t get working. I keep thinking that this must be a trivial configuration issue but I’m out of ideas. I even went as far as trying the ASIO4All driver, but that doesn’t even show up as an option in the Audacity settings. Any help would be greatly appreciated!


Audacity as shipped does not support ASIO. But even if you had compiled Audacity yourself with ASIO support, Audacity always mixes down more than two tracks to stereo for playback.

How you configure the Audiofire isn’t going to change that.


Gale, thanks for the wakeup call. As you can obviously tell I don’t know much about this yet but after you mentioned it I did remember reading that Audacity would need to be recompiled with a lot of crossed fingers to try to get it to work with ASIO.

I think you can use VoiceMeeter Banana to record multiple inputs of an ASIO device into shipped Audacity.