Audiobox USB doesn't register

Hi. I’m trying to use a Presonus Audiobox USB interface to record into Audacity. I have the latest version of Audacity installed from the .exe file and am running it on a 64-bit Windows 7 machine. I downloaded the latest driver for the audiobox from the presonus website and tried to install it on my computer, but I’m not sure if it installed correctly because it didn’t walk me through a set of install windows or anything after clicking on the .exe file, and then no driver is showing up on the programs list on my uninstall or change programs list. When I open up the devices preferences in Audacity (and with the audiobox plugged in), the audiobox doesn’t show up under interface host or under recording device. It does show up as a playback device and will work as such. Any tips on how to get Audacity to recognize my interface?

Thanks, -Dave

Go into the Windows Control Panel and ensure that it is enabled as a recording input - you probably want to set it as the default:
Then restart Audacity.

it says the drivers aren’t installed, but I’ve downloaded them and they won’t install. Any ideas about that? -David

What says that?

The latest AudioBox USB Driver installer v1.2.5194 from Universal Control | Downloads | PreSonus wants you to connect the AudioBox, then click “Install Driver”. If that doesn’t happen, try downloading a fresh copy of the installer.

Does Windows see the AudioBox (right-click over the speaker icon by the system clock > Recording Devices)?


I see this is a somewhat outdated post but heres a serious tip for anyone who precedes to have this issue. When I first got mine I was immediately put off because I too had driver installation issues, particularly the recording device one. I could use my audiobox to play back my guitar/bass/mic and computer etc, but my computer did not recognize it as an input. At first it seemed like a driver issue as my drivers still fail to update. The drivers were not the issue, it was the fact that the interface’s inputs were not recognized. Go to your task bar, right click the speakers, click recording devices. You should see a few things at first, a Line In option and a Microphone one if you use a headset etc for skype, gaming, or what have you. This is the key step. Right click anywhere in the box where your recording devices are listed and make sure that “show disabled devices” and “show disconnected devices” are both checked. Once you do this, two new options should show up, so long as your audiobox is plugged in of course. Option one, “Analog Connector 2-AudioBox USB” and “Stereo Mix”. Right click “Analog Connector” and click “Set as Default Device”. And like magic, next time you go to use a program on your computer (ie. Guitar Rig 5, ANY recording program, mixers etc) Analog Connector will show up and there should be a Analog Connector L and R (left right). Hope this helps someone out there and that they dont have to struggle with this issue as long as I did haha.

Thanks, as was stated in the second post in this topic: Audiobox USB doesn't register - #2 by steve

I’m glad it works.