Audicity won't pic up my mic.

I have a USB Blue Snowball mic, and it doesn’t show up in Audacity. I went to Edit → Preferences → and under recording the mic doesn’t show up in devices. I plugged my mic in before I opened up Audacity, and still it doesn’t show up. I opened and closed a Audacity a few times to make sure that’s not the problem.

Any ideas? Thanks guys

The Snowball has lights, right? Do they come on?

Does Windows see the Snowball? Audacity will do nothing until the computer sees the microphone.

Do you have Audacity set to stereo? Audacity may not connect to mono microphones (like the Snowball) if you do that. Audacity > Edit > Preferences > Devices > Recording.



It’s good to restart Audacity if there’s any question about it connecting to a device. You were right. Audacity checks for new devices and changes when it starts, but you can also Transport > Rescan… if you get tired of waiting each time.


Thanks for replying.
Windows recognizes it, it shows up on Control Panel > Sound > Recording > and it’s checked. The light is on and it works on programs like Camstasia, ect.
I set it to mono as you suggested and it didn’t resolve any problems.

Please read the pink panel at the top of this page and give us the missing information.

One thing you could try is shutting down the computer and restarting it.


Thanks Gale, I tried that as well. I have Windows 7, and have Audacity 2.0.5.

Thanks for confirming.

Is this an old Snowball? According to the Snowball manual, only models made after July 2007 with serial numbers higher than 76-065000 are compatible with Windows Vista. The same would apply to Windows 7 and later Windows.

If the Snowball is more recent than that, try right-click over the speaker icon by the system clock, then choose “Recording Devices”. Right-click over the Snowball then choose “Properties”. Then click the “Advanced” tab and set Default Format to a mono choice. Restart Audacity. Is the Snowball still not in Device Toolbar ?

Another thing you can try in “Recording Devices” is right-click over Snowball and choose “Set as Default Device” (if it is not already default). Then try recording with Windows Sound Recorder . What happens then?


It is brand new, and it does not show up in the recording devices. If I can’t get it to work I guess I’ll just record it in different programs and drag it over. I’ll uninstall and reinstall Audacity and see if that does anything first.

You meant that after setting it to mono Default Format in Windows Sound as I suggested, then restarting the computer with the mic connected, then launching Audacity, it is not in Audacity’s Device Toolbar ?

That won’t change your settings unless you check the “Reset Preferences” box in the installer:
Audacity Manual .