Audicity only flat lines trying to record from web[SOLVED]

I have visited

The suggestions from the above page were tried but I only get a flat line showing in the waveform.

I am running xp 2002.

I am running Audacity 2.0.2

I am trying to record from the web.

I can hear the music playing in my speakers.

I have Aud. set to:

Windows DirectSound
Realtek HD Audio Output
Realtek HD Audio Input
1 mono input channel

Thank you in advance for your reply.

The recording input device in the Device Toolbar needs to be set for “Stereo Mix”.
If you don’t have that option, what options do you have?
Sometimes “Stereo Mix” is called something else such as “What U Hear”, but some sound cards just don’t have the option to record sounds that are playing on the computer.

Thank you for your reply.

I have the following choices…

Primary Sound Capture Driver
Realtek HD Audio Input: Front Mic
Realtek HD Audio Input: Line Volume
Realtek HD Audio Input: Mic Volume
Realtek HD Audio Input: Stereo Mix

Which of these do you believe would be the best choice?

Thank you again for the reply.

I reset to “Stereo Mix” but the problem of no recording capability remains. I have used Aud. to record before on this computer but the program is not working this time. Can someone give me further suggestions or a troubleshooting procedure. I tried Windows built-in recorder but it would not record either. I tried another recording program but this program would not record. I checked Windows Help under sound recording but everything looks normal.

Stereo Mix is the best choice in Audacity. Do you have the input slider on Audacity Mixer Toolbar turned up?

You can also connect audio out to line-in with a cable and record from line-in. See that and the other alternatives further down the page you mentioned: .

Also make sure you actually have correct drivers for the Realtek device as supplied by the computer or motherboard maker (not Microsoft drivers). See this page for help:


Thank you. I will check these out and reply back.


The problem was not with Audacity, the problem was a setting in Win XP.

Here is how to solve this problem if you encounter the problem.

For XP users:

  1. Open “Control Panel”
  2. Double-click the “Sounds and Audio Devices” icon
  3. Click the “Audio” tab
  4. Under “Sound Recording”, hit the “Volume…” button. The “Recording Control” window should pop up.
  5. In the Recording Control window, hit Options, then Properties in the menu bar.
    6. Under “Show the following volume controls” make sure “Stereo Mix” is checked.
  6. Close the Properties window, then make sure “Select” under “Stereo Mix” is checked.
  7. Hit “Ok.”