Audcacity can't import MP4 [SOLVED]

I hope this is the right forum to ask this really stupid question.
Although I’ve been using Audacity for ages in v2.1.0 on a Mac under OS 10.11.4 I can’t seem to view any waveform when a song is opened. It was always there so therefore a no-brainer so now that it isn’t I can’t seem to find what might cause it to not show up. Any hints?

Describe your world in a little more detail. Which song and where is it coming from? Can you hear it? Is the track there but the blue waves aren’t wavy, like all you have is a straight line?

Is there no track there at all and you don’t hear anything (attached, click on it or scroll down)?

Screen Shot 2016-05-11 at 15.19.39.png

The songs (I’ve tried quite a few) I wish to edit are all coming from iTunes and, for the most part, are in mp4 format.
I can neither see nor hear anything. All I see is a blank Audacity screen.
All Prefs. are setup in their defaults-nothing has been changed. I can’t say that anything looks to be out of the ordinary there. (But then I most likely wouldn’t know.)

What was I supposed to see in that screen shot?

Tell me what else you need to know Koz and I’ll attempt to give you the answer.

You may have to install an additional component called FFmpeg into Audacity to play [and edit] that file format ,
here’s how …

That was true in Audacity 2.1.0, due to a bug

I would just update to Audacity 2.1.2 from Then Audacity will be able to import MP4 and other QuickTime formats without FFmpeg.


Thanks Gale-that did it