Audacity won't work with Windows 10.

I noticed that the “no device” problem with recording in Windows 10 (and latest version of Audacity) has been addressed. Based on that I downloaded older version 2.0.3 of Audacity, but still Audacity will not record any sound. I also went through this with a Microsoft representative for over an hour, and he could not get my computer to recognize a recording device so that Audacity would work. I had no problems with Audacity before upgrading to WIndows 10 (I had Windows 7). Can anyone suggest a remedy for this problem? Thanks.

Howard Wachtel
Email Removed by Elf

Can you roll the machine back to Win7?

Windows 10 is not an upgrade. It’s a New OS and lots of very nasty things happened to people who did the “simple upgrade.”

Audacity will not record any sound.

From where? What are you trying to record?


Thanks for your reply.
I am not going back to Windows 7. This problem is the only “nasty” thing that I have encountered after installing WIndows 10.

Neither Audacity 2.1.2 nor 2.0.3 will record any sound, no matter where or what. It makes no difference whether the sound comes from my own computer or a radio program streaming on the Web.

Howard Wachtel
email address removed by elf

So you’re recording “sound playing on the computer,” not for example, your own singing or playing the guitar into a microphone or interface or copying work from a cassette machine, turntable or sound mixer. Those are all examples of work originating outside the computer.

Recording internal sound requires the computer to play the sound, turn it around and send it back down the recording pathway, both active at the same time which is a special case.

See if there’s anything here.

I removed your email address. We are a spam magnet and it’s dangerous to post it.


On what audio device are the sounds playing that you want to record? And what recording device were you choosing in Audacity to record sounds before?

If the sounds are playing other than on the built-in sound device, for example on a USB headset, then the only simple way to record that is using the Windows WASAPI loopback method, and 2.0.3 does not have that method.

2.1.2 has that loopback method, but if 2.1.2 gives you “Internal Port Audio” error then you will need to upgrade the machine’s built-in audio drivers to Windows 10. If you are using an external audio device that has its own manufacturer-supplied drivers, you will have to upgrade those drivers too. See

Even using Audacity 2.0.3 to record sounds playing on the built-in sound device, you may still have to enable stereo mix or similar in Windows Sound and restart Audacity before you’ll succeed.


When running Windows 7 or XP, I had no problems with Audacity so did not delve into specific hardware. I do not have any of the external devices that either Gale or Kozikowski mentioned (microphone, turntable, headset or whatever). Now if I go to Sounds (by right-clicking on the speaker symbol in the system tray), I see the speakers listed for “playback”, but for “recording” there are 4 devices listed: Microphone, Microphone, CD Audio, Line In. Only one of these can be “available” at a time, and again I do not have an actual microphone yet. When I try to run Audacity on my current system, I have 5 choices for “recording device”, the 4 previously mentioned, and “Microsoft Sound mapper-Input”. It will not record any sound no matter which of these 5 I choose. Looking at the Audacity manual, my recollection is that “Wave Out” was in the recording box with earlier Windows versions. I do not know what a “loopback” is. Thanks again for your help.

Howard Wachtel

So, none of those are suitable for recording computer playback, except for Line In if you connect a cable between audio out and Line In and set Audacity in Device Toolbar to record from Line In.

I suggest you right-click in empty space in that Recording tab, and make sure “Show Disabled Devices” and “Show Disconnected Devices” are checked (ticked). If Stereo Mix or Wave Out then appear, you can use that to record computer playback. Right-click over the new Stereo Mix or Wave Out item and click “Enable” then restart Audacity and choose Stereo Mix or Wave Out as Audacity recording device.

If you do not have Stereo Mix or Wave Out then you cannot record computer playback with Audacity 2.0.3 unless by cabling Audio Out to Line In and recording from Line In. So if using a cable does not appeal to you, you will need to use 2.1.2 or 2.1.3-alpha and use the Windows WASAPI loopback method of recording computer playback. See this link for explanation of WASAPI loopback - it applies to Windows 10 too

If you were getting “Internal PortAudio Error” in 2.1.2, and no devices listed, then as I said, you must go to the web site of your computer manufacturer (or motherboard manufacturer if you built the computer yourself) and obtain the latest Windows 10 audio drivers meant for that computer or motherboard.

There is no getting round this. If you update Windows on the same machine you should update drivers for components on the machine to the new version of Windows. If you need help with that, please give us the make and model number of the computer (or the motherboard details if it’s a self-built computer).

If no Windows 10 audio drivers exist for your computer or motherboard, then your only chance is to try 2.1.3-alpha. See this link

Disclaimer: please make sure you have copyright holders’ permission before recording computer playback.


I tried using Windows WASAPI for the audio host as suggested in earlier message, The recording device is listed as “Speakers…(loopback)”. For the first time since installing Windows 10 I was able to get Audacity to record sound. However, the sound waves are visibly reduced in amplitude, so when I play back the recorded sound, it is weaker than the music that was recorded. I have never experienced this problem with Audacity before. [Also I never got an “Internal Port Audio” error and the drivers are up to date.] Do you have any suggestions on how I can get the full recorded sound (as I did before installing Windows 10)? Thanks again.

WASAPI loopback does (usually) record at a fixed level.

You have not said clearly if you went to the computer manufacturer’s site to obtain Windows 10 audio drivers. The drivers that Windows 10 finds may not be properly matched to your motherboard.

You can import song files into Audacity rather than record them and you may be able to download songs from some sites instead of recording them. Use your favourite search engine to find out how to download songs that you hear on web sites.

Or use a cable. You have a proper blue stereo line-in, from what you said. Double the computer output with an adaptor if you want to hear the song while recording, or use Software Playthrough in Audacity.

Or, use Effect > Amplify… after WASAPI loopback recording. That should not increase surface noise to any great extent, assuming the peaks are about 0.5 on the vertical scale.