Audacity wont run [SOLVED]

I have installed via apt

when I try to run AUDACITY I get this error in terminal:

(Audacity:6189): Gtk-WARNING **: gtk_disable_setlocale() must be called before gtk_init()

any help would be appreciated!

thanks dan

That’s just a warning, not a critical failure. I get that warning too, but no reason for it to prevent Audacity from running.

well that’s not true fro me.

After the error , terminal goes back to cursor.

However if I run Audacity as SUDO it start but I get …

“Audacity could not find a place to store temp files, click to select a place”

so I click and

"preference directories’ opens

pre selected is “var/tmp/audacity-root”

set ok,

says will now exit, restart to use directory.

I do that and same dialog repeats.

SO I created a new directory

which the auto creates


so restart again and no joy.

back to same dialog

“Audacity could not find a place to store temp files, click to select a place”

so I don’t know why this is happening and I don’t know why it wont even start unless sudo.

Thanks DAN

not for me, it does not run at all


Audacity should not be run as sudo.

What repository is that from?
I’m using Ubuntu 16.04 and Audacity is listed as 2.1.2-1 (

Yes I know audacity should not be run as SUDO,

for me that is the only way it will run.

repository is xenial

installed version is



Try removing that version completely, including any user settings ~/.audacity-data and ~/.audacity-files (both are hidden folders, and are created per user).
Then install Audacity from the Ubuntu main ‘Universe’ repository.

removed audacity

sudo apt-get purge --auto-remove audacity

unchecked repository of audacity

installed via “ubuntu software” GUI

same problem!

will not even start as non-sudo.
starts in sudo.

checked folders/files against my 14.04 machine, and they are the same permssions

when I open in sudo, it ask me to set tmp directory.

So I do set as /var/tmp/.audacity_temp

permissions are owner root, group root.

and it runs ok.

if i change permission of .audacity_temp to owner me, group my-group

it will not run normally OR as sudo.


Did you forget about ~/.audacity-data and ~/.audacity-files ?

That will not allow Audacity to run correctly, and that is not the correct default location for Audacity’s temp folder.

from what I found on inet,

sudo apt-get purge --auto-remove audacity

was supposed to remove all including data files.

None the less I will try individual removal of those 2 folders.

As for default tmp folder,

/var/tmp/.audacity_temp is what the program is going to automatically,

so where should the tmp foldr go?

Thaks Dan

removed .audacity folders

reinstalled program , runs now!

thanks for help

I’ll mark this as solved.

For information:
“sudo apt-get purge --auto-remove” will remove the application and configuration / data files of the package, and dependencies that apt thinks are no longer required.
The “purge” option does not remove user files created by the application. User preferences that are saved by an application are not “files of that package” - those files were not installed by apt and apt does not know about them. It is normal for preference files to remain after uninstalling - typically within a hidden “dot” file or folder in the user’s home directory. These files are typically small and can be useful if you want to reinstall the application at a later date.

In this case, the problem was in one of Audacity’s user configuration files (probably in audacity.cfg), which by default is in ~/.audacity-data

Note that the “–auto-remove” option is risky. If you have any applications that were not installed with apt but by some other means, apt will not be aware of its dependencies, so this option could remove packages that are still required. This shouldn’t be a problem if you only install applications from the distribution repositories and use apt or an apt front end (such as Synaptic), but best to always check exactly what is being removed before allowing this option to run.

Thanks for the above discussion.

Simply renaming the audacity.cfg file to audacity.cfg.bak enabled me to be able to start Audacity, at which time it created a new audacity.cfg.

Now I need to compare these 2 files and reset my essential cfg settings.

This relatively non-destructive solution should work irregardless of Linux or Audacity version.
Not sure if it work on Windows or not.

Linux Xubuntu 18.04 LTS
Audacity 2.2.1

I would like to add - after renaming the corrupted cfg file…
and restarting Audacity (during which Audacity automatically
and it recreated a default cfg file.

I used Meld (a popular tool in the ubuntu repos) which is an excellent
linux GUI text file comparison tool to selectively update the new cfg file
with essential settings.

Meld is similar to using windows notepad++ for editing files based on
[Advert Removed]
After this incident of a corrupted cfg file, it also it seems wise to backup/copy
the cfg file for robust recovery.

What I do is:

  1. Do a clean install of Audacity (remove the three .cfg files before installation)
  2. Launch Audacity.
    Audacity should always be able to launch after a clean install. If it can’t then that’s a serious bug that needs to be urgently fixed by the developers and I won’t waste my time with the software until it is fixed.
  3. Configure Preferences the way that I like them.
  4. Restart Audacity to check that all is well.
  5. Make a backup copy of the three .cfg files.

Based on anecdotal evidence, it appears that some very recent releases of Audacity may not be fully compatible with previous versions and may require a clean install rather than an upgrade.