Audacity won't record

I’m trying to use Audacity to digitize a collection of old Vinyl LPs. I’m running Audacity version 3.1.0 on MacOS 10.15.7 on a MacBook Pro.

The line out from my pre-amp is connected to an old Griffin iMic, and the USB from the iMic is connected to the MacBook. I’ve I set up Audacity’s “transport” section to use “Core Audio”, “iMic USB Audio System”, “Stereo Recording” and “Built-in Output” (which is my headphones). Nevertheless, when I press record, nothing happens; I see no waveform, the input level meters show nothing, and there is no sound on the headphones.

In contrast, using Quicktime Player and Garage Band, I can record audio from the iMic USB Audio System without any problem. I can then import this audio into Audacity, and edit it — the editing, including splitting tracks and pop removal, seems to work fine. But recording doesn’t work at all.

As an experiment, I’ve also tried recording form the built-in microphone. This also fails in Audacity (but works in Quicktime Player).

This was a new installation of Audacity. I’ve tried re-booting the MacBook. Soundflower is not installed — should it be? What am I doing wrong?

You might need to give Audacity permission to use the “microphone”.

See this forum post:

– Bill

Yeh! That fixed it. Thank you very much.

Is there some reason that Audacity doesn’t tell me that it can’t open the input device? For example, is it a security “feature” of MacOS that MacOS doesn’t tell the app that opening the device failed, but instead pretends that it has succeeded, with zero signal?

I’d guess it’s something like that, but I don’t really know :wink: