Audacity won't record [SOLVED]

I can hear my mic and guitar through my speakers, so the mic (and mixing board) are working fine. When I press record I get “!Error while opening sound device. Please check the recording device settings and the project rate sample.”

OK, I checked them. They seem to be what they always have been (I was recording fine using Windows 7 but just “upgraded” to Windows 10).

Did the Windows upgrade do something? Did I likely do something? Any help greatly appreciated!
Thank you!

Windows 10 Home on hp pavilion desktop p7-1010, 6GB ram
64-bit, x64-based processor

Audigy 5/rx sound card
Audacity 2.1.2
Playback: Speakers (Sound Blaster Audigy
Recording: Line-In (Sound Blaster Audigy 5
Channels: 2 (Stereo)
Rate: 44.1 kHz

You probably need to update the sound card drivers for the 5/Rx to work fully with Windows 10.

Thank you, Steve. I wish I could say that solved it… but no. I just downloaded the latest driver for my audigy 5/rx soundcard and as it is an .exe file, ran it.
It didn’t change anything, unfortunately. I wonder if “Supported Rates” is the problem. But if so, how do I change that? Here is my device info:

Device ID: 3
Device name: Line-In (Sound Blaster Audigy 5
Host name: MME
Recording channels: 2
Playback channels: 0
Low Recording Latency: 0.090000
Low Playback Latency: 0.090000
High Recording Latency: 0.180000
High Playback Latency: 0.180000
Supported Rates:

Again, any help greatly appreciated!!

btw I downloaded and ran SBA5_PCDRV_L11_3_01_0046.exe from Creative Labs (263 MB) which their website claims is the latest driver and software for Audigy 5/rx.

Look at the complete Audio Device Info to see the sample rates that Audacity thinks Sound Blaster supports. Press OK in Audio Device Info then you can save the complete information to a file and attach the file here. Please see here for how to attach files:

You choose the Audacity sample rate in Project Rate bottom left of Audacity.

What Audio Host are you choosing in Device Toolbar? Try another host. Are you overdubbing against an existing Audacity track? WASAPI host may error if you are overdubbing, unless sample rates for both playback and recording are correct in Windows, SoundBlaster and Audacity.

There is some information here about sample rates It applies to Windows 10 just the same.


Hi Gale,
Thank you for trying to help! I am on MME. If I change it to Windows Direct or WASAPI I don’t get an error but I don’t get a recording. If I leave it on MME I get the error described above. I am attaching my screenshots in hopes that will give you a better clue as to what I am doing wrong.

What should I try next?

Do you have the guitar and mic connected to the mixer then the mixer connected to
Line-In of SoundBlaster?

When you change host do you also check the Audacity recording device is the Line-In?

When you change host does the Audacity Recording Slider ungrey?

If the Audacity recording slider is greyed, as it is when MME host is selected, this means that Audacity cannot set the recording volume. You must open Windows Sound, Recording tab, double-click SoundBlaster Line-In and set the recording level on the “Levels” tab.

For more diagnosis you can make the SoundBlaster Line-In the default recording device in Windows Sound and see if “Windows Sound Recorder” can record a signal. To open that app, press Windows Start, type “recorder” (without quotes) then press ENTER on your keyboard. Click or tap the microphone icon to start recording, and click or tap the Stop button when you’re done.

To stop the MME error, double-click the SoundBlaster Line-In on the Recording tab of Windows Sound, click the “Advanced” tab, then try changing the Default Format to match with Audacity project rate (or vice-versa). Or, try enabling the “Exclusive Mode” boxes in Default Format and choose Windows DirectSound or Windows WASAPI as Audacity audio host.

Restart Audacity after making changes in Default Format.

Another thing you could try if you are not overdubbing is to turn off Transport > Overdub in the Audacity menus.

If you need more help, please save the complete Audacity Audio Device Info as I suggested and attach it.


Issue resolved. I uninstalled my sound card and reinstalled it in Windows 10. That did the trick. Thanks Steve and Gale for your comments and help.

I’m glad it seems to have been resolved.

When you reinstalled did you then run “SBA5_PCDRV_L11_3_01_0046.exe” again?

Yes sometimes uninstalling before reinstalling can help. Some installers will automatically uninstall and reinstall for you.

Did you reboot after the original reinstallation? That is important too.