audacity won't recognize USB device

I have a USB cassette capture device that connects with a basic USB cord to my MacBook and is powered through the USB port. The device has worked in the past but now I cannot get Audacity to recognize it. It is not available as a choice in the Apple sound preferences and not in the Audacity preferences. I have tried many cords. Is the cassette deck port defective now or am zI missing something?

I am running 10.7.5 on a 2011 MacBook Pro. Audacity 2.1.1. I have tried rebooting Mac Book, re-connecting usb cable to cassette capture device, going to Sound preferences in the Apple menu (only internal mic available there still) then opening Audacity, but usb device still not available as option.

Apple (Desktop upper left) > System Preferences > Sound > Input. If your device isn’t listed there, it doesn’t exist as far as the Mac is concerned.

Audacity gets sound devices from the Mac, so there’s no such thing as fiddling with Audacity to work around this. If The Mac finds it, you may have to restart Audacity for it to show up. Audacity does have settings that can affect this like Mono-Stereo. For example, I have a microphone that only arrives in Audacity if I set Audacity for Mono.


Aha, I had been struggling with the same problem until I realised that the simple solution was to make sure the USB input was connected and live before launching or re-launching Audacity, this appeared somewhere in the forum and in the user manual, but has got me up and running no problem. (iMAC running latest Yosemite, Audacity 2.1, Climax Audio Capture USB device).