Audacity won't play through headphones

I’ve seen this posted before with no satisfactory answer, so here was the resolution for me:

Problem: You have headphones plugged in or connected via USB. Other apps play through the headphones no problem, but Audacity only plays through the PC speakers. Within Audacity, you can’t see anyplace to change the audio output device or you see it but it’s greyed out.

Solution
1: Close Audacity
2: Right-click the Audacity shortcut and select “Run as administrator”
3: In Audacity open the “View” menu and select “Toolbars.” If “Device toolbar” doesn’t have a check next to it, click it.
4: Right below the play controls you should see the options for the input and output devices. Change the output device to your headphones.

Running an app as Administrator should only ever be done when you want to make changes to the system, such as installing or uninstalling apps, adding or removing users, or other administrative tasks. Running apps as Administrator in any other circumstances is a huge security risk as it grants permission for the app to do anything to the system, bypassing much of Windows security.