audacity won't play imported track when recording

I’m using windows 10

I’m using audacity 3.1.3

As the title says, audacity won’t play imported track when recording.

I have exhausted the suggestions on the internet, and that is why I’m here asking this question.

To play existing tracks while recording, Transport > Transport Options > Overdub.

You may find this useful: Tutorial - Multi-track Overdubbing

Thanks for the quick reply!!

Overdub is activated.


I neglected to elaborate.

Overdub is activated, the issue, like the song, remains the same.

So here I am guessing why is working for everyone but you.

Did you find the tutorial useful ?

Can you post a screenshot ?

I did read the tutorial.

Nothing has changed.

What would you like a screenshot of?

At what step in the tutorial are you having difficulties ?

Why not start with the Full Window ?

Screenshot (1).png

Screenshot (3).png
The first image is the wrong image.

I don’t know hot to delete it.

This is the correct image.

The image is very helpful.

The image does not show any freshly recorded audio. I’m thinking perhaps you have Transport > Transport Options > Sound Activated Recording turned on.

Otherwise, three questions:

  1. Can you play the original track without trying to record ?
  2. Can you record into an empty project ?
  3. Did you install the Rubix22 driver? See here:

Sound Activated Recording was not turned on.

  1. Yes, I can.
  2. Yes, I can.
  3. Yes, I did.

So in your terse reply, you neglected to offer whether or not the issue still exists.

You can try changing your Audio Host from MME to WASAPI to see if that fixes the issue.

After scanning through the Rubix22 manual, it appears that the default sample rate is 44100 Hz, which is what your project is set for, so this shouldn’t be a problem. However, in some cases it is, so lets try changing Audacity’s project sample rate to 48000 (lower left-hand corner) and see if that changes anything.

Thanks for continuing to help.

I tried changing the audio host to WASAPI, and when I press record, now it records the imported track, as it’s playing.

Which is a slight change, as Audacity didn’t run at all, when I pressed record with an imported track.

I also tried changing the sample rate to 48000, and got the same result.

And I tried using WASAPI, and the 48000 sample rate at the same time, and got the same result.

Lets set the project rate back to 44100, as it seems to make no difference on this issue.

Check that Transport > Transport Options > Software Playthrough is turned off.

I’m thinking that there may be some parameter or control in the Rubix22 driver or hardware that is looping this back. See if you can’t find this. In the mean time, I’ll take a look at the Rubix22 manual myself. 'Later.

And you know this because you have solo’d the newly recorded track and can hear the “imported” track in the background?

After perusing the manual, I cannot see anywhere in the hardware where there might be a loopback situation causing the imported track to be re-recorded.

If you are monitoring the “imported” track with speakers, they will of course bleed back into your microphone input. Sometimes, this can happen with headphones as well, although typically to a far lesser degree.

Other than that, I am out of ideas. Perhaps someone else will chime in. :smiley:

After turning off the computer for awhile, now the original problem has returned.

It no longer plays the imported track, when I press record.

With the imported track on one track, when I press record, the green arrow turns red, and Audacity doesn’t run.

Yes, it plays the track solo.

Software Playthrough is turned off.

Hopefully, someone else will chime in…

Did anyone find a solution to this problem?

What are your settings in the Device Toolbar?

Thanks for the reply.