Audacity won't open

Hi Folks,

Audacity isn’t opening. The splash screen displays, but after that it crashes, sometimes prompting an error report.

This on a fresh reboot of Windows 10 Pro v 21H1. Was working fine until recently. There was a recent Windows update, but I’m not sure that correlates with start of problems, it might.

Things I’ve tried:
I went and got a fresh copy of most recent version of Audacity and overwrote on install. Same result.
Then I renamed remote appdata folder to force new instance. Same result.
Then I completely uninstalled, before reinstalling. Same result.

All same result, crashes after splash screen without opening.

Any ideas or suggestions? Thanks…

You seem to have been pretty thorough in your efforts. :smiley: I’ll make some comments that may inspire further investigation:

Do you care to share?

This can be one of the very first things to check.

Check to see if there were any problems with the updates: Windows > Settings > Update And Security > View Update History
Also, it can be worthwhile to run “Check for updates”, just to see if there are anything was missed and install them if so.

Did you download from here: Audacity ® | Downloads ?

Did you rename the appdata folder or the AppData/Roaming/audacity folder?

This is always a good idea.

As before, is there an error message in the crash?

So when Audacity first starts up, it scans all of your Audio I/O devices. There is a possibility that it is getting hung up one one of them. You can try disconnecting any USB or HDMI devices to see if they might be associated with the issue.

I downloaded the latest Audacity version on my Windows 11 PC with no error messages but Audacity would not launch from task bar icon or start menu. After trying many possible fixes from the forum, I finally got an error message that said Audacity.exe needed to have write privileges so I checked the “write” box under properties and Audacity now launches correctly and is working great.