Audacity won't open on MacbookPro [SOLVED]

I’ve used Audacity for years. Including just a week or so ago. Tonight I opened it to import and edit a new piece of music. It seemed to open but the “How to get Help” window that always opens with the OK box was frozen. I could not close it - it just beeped every time i clicked. it. Likewise all of the Audacity drop down menus were greyed out - nothing was active, not even Quit. I had to Force Quit and start over. I did this multiple times with the same result. I also tried restarting the compuer and shutting down completely and rebooting - same result. At that point I figured there might be a newer version and indeed there is. So I downloaded it, installed by dragging the folder into Applications. I DID NOT run it from the DMG and I left the app in its folder. Again same results. I’ve downloaded the app twice now and still the same results.

I do not understand what is happened. I’ve changed nothing on my computer, added no new software, etc. All of a sudden it simply woould not open and neither will the newly installed version. I’m on a MacBookPro retina with OSX 10.9.5.

Any ideas???

If you have tried to retinize Audacity this can cause problems.

Make sure you got Audacity 2.1.0 from this address:

Then, see If you’ve not installed new plugins or connected new audio devices, follow the steps in that link to reset Audacity Preferences. That is, force quit Audacity, open Finder, Go > Go to Folder and type:

~/Library/Application Support/audacity/

Then delete the audacity.cfg file in that folder.


OK - I trashed the audacity folder and the downloads - cause got it somewhere else apparently. I downloaded form the link you provided. Opened Audacity and the same issue - it froze before I could even click the OK on How to Get Help screen. I closed it and then followed the link you provided - used finder to go to "library/audacity support/audacity so I could delete the audacity.cfg folder and thus reset preferences, but finder says “The folder can’t be found.” How can that be following a complete fresh install??

Indeed I manually went to Library/App support/ and there is no audacity folder?

You missed the “~/” in front of “Library” in the path to the folder.

  • Bill

Doh! My bad. That fixed it - thanks!!