Audacity won't launch after new install on MacOS X Catalina 10.15.7

I have spent hours trying to troubleshoot this on my own and am officially at a loss. I’m hoping someone here can help me. I apologize in advance for the length.

I originally installed Audacity 3.4.2 (universal DMG) as I’m running OS 10.15.7 - on the download page (Audacity ® | Download for Mac OS), it states that versions 10.14 and earlier should use the Intel DMG, so I figured I should be okay using the universal one as 10.15 is later than 10.14. The application seemed to install, but when I tried to open it, the icon appeared in my dock and bounced for a few minutes. After a while, it stopped bouncing and didn’t have a dot under it indicating the program was open. When I right-clicked on the icon, it said “Application Not Responding,” so I had to force quit the application. Even when it was bouncing, I had the option to “Force Quit”. There was no error message.

I uninstalled the application and deleted the DMG file, then installed 3.4.2 using the Intel DMG. The same thing happened: It installed, but the program icon just bounced a bunch before stopping and not launching.

I then rebooted my laptop and tried opening the program again, and the same thing happened. I uninstalled and reinstalled the program again (using the Intel DMG), but this time rebooted before launching. Again, the same thing happened.

I then saw that some people recommended deleting certain files in the ~/Library/Application Support/audacity folder, so I went to find them only to discover that no such audacity folder existed in my Application Support folder (which I think is because it never managed to launch in the first place… but I could be wrong).

I also made sure that my permissions were set to “Read & Write” for my user account under the “Get Info” panel, which it was (though the admin was set to “Read Only”… I didn’t think that was a problem).

Then, I read the troubleshooting section in the 3.4.2 manual. I followed the instructions to set my privacy settings to accept downloads from “Anywhere” and not just the app store and trusted third parties (which meant I had to go into the Terminal to make that option available). After that, I tried re-opening the program. The same thing happened, that infernal bouncing. I then uninstalled and re-installed Audacity 3.4.2 AGAIN (Intel DMG) with the privacy settings on “Anywhere”, which didn’t work either.

I then bit the bullet and tried to install older versions, even though I was sure the current version should work on my machine. I installed 3.4.1, 3.4.0, and 3.3.3 (with privacy settings still accepting downloads from “Anywhere” and using the Intel DMGs), all of which resulted in the same thing happening.

That’s when I gave up. At this point, I’ve uninstalled Audacity, deleted all the DMG files, and reset my privacy settings to default. I even cleared all the downloads in Firefox while trying to troubleshoot, but that didn’t help either. And not once did I get an “audacity” folder in ~/Library/Application Support. I also tried downloading 3.4.2 from the official Audacity Mac download page and on FossHub, both of which had the same result. On my last try, I noticed in Finder that Audacity was blank under the “Kind” column when it should’ve said “Application”. However, when I opened the folder to see the package contents, there were folders and files inside (i.e., it wasn’t “empty” and took up hard drive space - if memory serves ~89 KB). It also isn’t a capacity thing. I have a 1 TB drive, and only about a quarter of it is in use.

Any ideas on what’s going on? Any help would be much appreciated.