Audacity Won't Export the full Audio.

I’ve been using Audacity for a while with no problems, but recently I started recording voice overs for things, which usually end up being a length of 1-2 hours. I’ve been having a problem where for some reason or another after I’m finished editing the audio and I try to export the voice in .wav or .mp3(which I tried after wav failed) it’ll take about 5 minutes and then just say it’s finished even though the final audio clip is anywhere from 3-15 minutes of the goal 2 hours of audio. I haven’t been able to figure out why it’s happening and was wondering if I were doing something wrong somehow, I thought at first that maybe the audio was just too big so I split it into several projects but it’ll still only actually export proportionally smaller clips of the audio. I’m just using the normal export options and all the settings are default from a fresh re-install. Any thoughts on what I’m doing wrong here?

Please always read the pink panel at the top of the page and give us the details of your version of Audacity and Windows.

Please check that you have sufficient space on the drive you are exporting to. If the WAV export gave an error that the saved file did not match what you were exporting then lack of space is very likely the problem.


I have 80 gigs of 930 free on the drive I’m saving it to, Does Audacity need more room than the actual file takes up in the end to actually export it? The 15 minute pieces on my drive are only about 5 gigs, so an hour and a half shouldn’t be larger than 80 gigs. But I’ll move some projects to an external drive and let you know if that fixes the problem.

I went ahead and dumped a whole bunch of stuff off of all drives that have ever even remotely been involved in Audacity and the problem persists for some reason. I’ve got over 200 gigs free on both my active drives and It still won’t save anything longer than 15 minutes. Also the version is 2.0.6, It slipped my mind completely to put the version number, sorry.

If your Default Sample Format in Quality Preferences is 32-bit float (the setting it ships at) then 90 minutes of mono audio takes almost 1 GB to import, and 90 minutes of stereo audio takes almost 2 GB to import.

Then every edit of the entire 90 minutes takes another 1 GB (mono) or 2 GB (stereo), because Audacity stores each edit as data so you can undo and redo edits.

If you need to free some space while you are working on the project you can do so at View > History… .

Make sure you use Export and not Export Selection.


I tried it just now with a fresh unedited 30 minutes of sound and it ended up being about 2 minutes long once I exported it. I now have hundreds of gigs free on both drives so that isn’t an issue anymore. I even renamed the project a few times and saved it a couple extra times, and for some reason the files are all of differing sizes despite being the exact same length, one of them is even larger than one of the 5 minute ones from earlier. I don’t even. Something’s broken. :neutral_face:

If you are exporting to different formats the exported files will be of different size according to whether the format you exported to is compressed (like MP3) or uncompressed (like WAV).

So why don’t we have this problem on our machines?

I suggest you uninstall 2.0.6 and obtain the 2.1.0 installer from us at Audacity ® | Download for Windows. Half way through installation, be sure to enable the box “Reset Preferences” then when you start Audacity, say yes when it asks if you want to reset preferences.

How many drives do you have as well as C:? If C:\ is a small partition for boot or recovery, then it’s no use exporting there.


Did a new install of the newer version that you linked to, pulled up old projects, still have the problem, imported new audio, still have the problem. I have 2 drives in total, C: has 248 Gigs free on it and E: has 353 gigs. And all the files I’m saving are .wavs at this point, I saved one .mp3 a while back to see if it was just the .wav export option but its not. I reset the preferences and everything when I installed the new version but I still can’t get full audio exported. The actual file size at the end seems to be roughly what I expect the full audio file to take up, even though its only 2, 5, or 15 minutes. And if I cancel the export halfway through I actually end up with way more of the actual intended audio file, I canceled the export of an hour project halfway through and ended up with 26 minutes of audio for example, but if I wait until the last 10-30 seconds of the export to cancel then it ends up being exactly the same length as the broken versions. As it stands it looks ridiculous in my folder with 2 minutes of audio taking up more space on my drive than 26 minutes of audio when both of them are .wavs with the same bitrate and exported with the exact same setting.

I didn’t mean to imply that everyones is broken, I’m sure I’d see threads about it on this forum. Simply that somehow or another my install of audacity is not working.

Has your IT manager imposed space quotas on the drives?

Have you done a S.M.A.R.T check to see if your drives are dying?

Do this after launching Audacity 2.1.0 supplied by us:

  1. If the Audacity project rate bottom left is not 44100 Hz, make it so.
  2. Generate > Chirp…, 2h 00m 00s. You’ll see a tone starting loud (tall) and getting quieter and higher pitched.
  3. File > Export Audio… and choose “WAV (Microsoft) signed 16-bit PCM”.
  4. Let the export dialogue with the bars complete.
  5. If Audacity gives an error message, tell us exactly what the message says.
  6. Explorer should show that the exported file is 605.6 MB.
  7. Drag the file back into Audacity. Does it look the same as the tone you generated?