Audacity with Xone 96 Mixer - No or Very Low Signal in Audacity

Windows 10
Audacity 2.3.3

Hi guys,

I recently purchased a Xone 96 Mixer from Allen & Heath and have been trying to record my sets in Audacity, but sadly I am having issues.

The peak meters on the mixer are alive (boucning into the greens and reds), plus Traktor software is able to record the output from the mixer with no issues, but sadly no life in Audacity.

My audio choices are:

Microphone: Line (Xone 96 USB 1), 2 Stereo Recording Channel
Speakers: I have tried both the Xone 96 USB choice, as well as the default laptop speakers Conexant SmartAudio

My sample rate is at 44100Hz.

I hit record and see nothing on the waveform:

Life in the Traktor recording meters seen here:

Appreciate any help.

Bump - if i may

Traktor is probably using ASIO, which will lock out non-ASIO applications (such as Audacity) from the recording device while ASIO is running.

Yes you’re right. Is there a work around to not lock out Audacity? I attempted to change the driver selected but then the mixer doesn’t appear to work.

Can you run Traktor with WDM or Direct Sound instead of ASIO?

HI steve, unfortunately not, doesn’t seem possible from what i’ve been trying to read up on the past few days.

That’s a shame. That would have been an easy workaround.

The only other workaround that comes to mind, is that you “may” be able to run Traktor with “ASIO4All” (
ASIO4All provides a kind of “fake ASIO”, that is intended to provide ASIO compatibility, while actually using WDM. This “may” allow you to use Audacity with WDM at the same time. I am not able to test this as I don’t have Traktor or any other ASIO software (I usually use Linux).

Hi there,

As I can see from the above thread there’s issues with Audacity pairing up with a Xone 96 mixer. I’m I right in saying it won’t work In any situation? I’m a vinyl DJ and have used Audacity for a very long time, I have the same issues as above but I’m not running Traktor etc, is it a lost cause? I can obviously still use it through my external audio interface but that kind of defeats the purpose of having two built in sound cards in the mixer.

Any help appreciated.


Does the Xone 96 mixer show up in the Windows Sound control panel?
If so, is it enabled, and do you see the green meter in the Recording tab respond to input from the Xone?

The Xone manual says, “Microsoft Windows® PC: In order to access the soundcard channels on your XONE:96 you will need to install the dedicated, ASIO* compatible, Device Drivers, which can be downloaded from the Allen & Heath website”.

For licensing reasons, Audacity does not ship with ASIO included. It is however available for free. All :wink: you have to do is compile your own private version of Audacity. See here:

I hope this helps. :smiley:

I endeavored to change the driver chose however then the blender doesn’t seem to work.

Thanks for the help.
I’m using a Mac so I think this complicates matters?
I contacted Allen & Heath as well and sent his reply.

he Xone:96 is fully supported on Mac OS 10.15 Big sur (currently Intel-based machines only)

We have had a few reports of this, plus we have tested it out in-house and got the same result. It’s basically down to how the Audacity software manages core-audio compliant devices. As to why it works that way, you would need to consult with the software developers. I would like to add that there is nothing wrong with the mixer. We do know that the Audactiy software works fine with the ASIO driver that we have available for Windows. So if you are married to that particular piece of software and have access to a PC, maybe try going down that route!?

A workaround for Audactiy on Mac would be to use stereo input one as your record bus send. this will only work so long as you are not using channel 1 ‘line’ input for anything. The idea would be to connect from the RCA record output, to channel 1 ‘line’ in, then make sure the USB routing switch is set to ‘LN’. The signal will then be sent directly to USB streams channels 1&2, which are the only two channels that seem to work in Audacity on Mac (core-audio). Finally, make sure channel 1 input selector is not set to LN with the fader up! As this would cause a feedback loop.

Using up an input Chanel isn’t ideal. At least it’s a reply.

No. You do not need ASIO for Mac.

So you have that. Also check permissions. See this post:

And here:

Are you on Audacity 2.4.2 ?

And what steve says:

I hope this helps. :smiley:

I had already checked the microphone settings, they are all set up correctly.
I’m using the most up to date Audacity.

Thanks for the help.