Audacity will only play via HDMI, and window size is suddenly enormous!

I have started to have the strangest issues with Audacity. For years and years, I’ve used the program without much trouble, minus occasional crashes.

Recently, maybe the last few months, I’ve started to have issues with Audacity not being able to play or record audio (at least the proper channels – all I have is HDMI). I’ve realized that this is because other programs are claiming the audio, and this is foreclosing Audacity from using it. It’s strange, because I’ve never had this problem before a few months ago, and other programs – like - Ocenaudio are able to still play and record without issue. I’ve had some success shutting down programs, but this doesn’t always work, and sometimes (I feel, at least) I’ve had to adjust my audio output etc. settings.

Second, a few weeks ago – I believe after upgrading form Fedora 30 to Fedora 31 - the window size is huge! No other fonts or settings from any other program were affected, so I’m not sure where this is from or the settings to adjust. I’d really like to shrink this down again.

I’m on Fedora 31 and run Cinnamon, running audacity-freeworld-2.3.3-1.fc31.x86_64 (have tried also audacity-2.3.3-1.fc31.x86_64), installed via dnf.

I know this is light on specifics, but I’d immensely appreciate any pointers.

Thanks a ton for any help!!
Screenshot from 2020-02-17 18-59-07.png
Screenshot from 2020-02-17 18-58-56.png

You could try setting the playback device to “default”. That will tell Audacity to use the system default playback device, which is “Pulse Audio”. That “may” make Audacity prone to freezing when starting or stopping playback, in which case that is not a viable option on your machine and we will need to think of something else.

If this continues to be a problem, please start a new topic (and include a link to this topic), so that we are not trying to talk about two different issues at the same time in the same topic (I don’t think the sound problem is related to the window size problem).

What is"huge"? Are the fonts huge? Are the buttons huge?
Is Audacity being displayed full screen?
Can you resize the Audacity window? (I assume that you know how to resize application windows, but please say if you don’t).

Hi Steve, thanks a ton for the response, I appreciate it.

Regarding the sound, I didn’t even have the option of “default.” All I had were the HDMI options. I decided to install alsa-plugins-pulseaudio, and that seems to have done the trick (actually I went all out: alsa-plugins-pulseaudio, paman, paprefs, and pulseeffects). Now I can set the audio to default and all plays ok. I’ll start a new topic if it becomes an issue again, but I think it’ll be ok from here on out.

Regarding the “size” issue - when I load audacity, it looks like the DPI increased by like 300%. Literally every part of the Audacity UI is large - the buttons, the menus, everything. Thinking of it as a DPI issue, I dug around a bit more, and it appears (?) to be a HiDPI scaling issue, much like as shown in the screenshot of

I think the post on this forum, (Re: Force Audacity to scale to High DPI screens (*ubuntu)), speaks to this matter.

It’s so strange because I swear I didn’t have this issue before the Fedora 30 → 31 upgrade… Has any thing changed since the date of the above post - are there any other methods I could try - or should I still try to follow those instructions to see if that fixes it?

Thanks very much!

Which post are you referring to?
If you mean this wiki page:
That was written about 4 years ago, and a lot has changed since then.

I’ve not had much success building with gtk3, so I’ve always used gtk2 (which is the default for the system wxWidgets on my machine). The large scaling could (I’m guessing) be due to Fedora updating from wxgtk2 to wxgtk3.